About Java Issues

Discussion in 'Official Announcements' started by Biztart, Jul 22, 2014.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
  1. Biztart

    Biztart Exceptional Talent

    If you are facing issues with Java 7.65, please follow the Guide in our Technical Support section to address your problems. We apologize for the inconvenience this has caused.
     
  2. The latest Java version, Java 7.67, appears to be working very will with DSO.
     

Share This Page