Support Broken (?) Dwarven Ambassador Quest

Discussion in 'General Archive' started by Mindship, Aug 31, 2015.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
Thread Status:
Not open for further replies.
  1. Mindship

    Mindship Forum Inhabitant

    I am stuck on the Dwarven Ambassador quest, part 2, cuz it looks broken.
    -- I found the Rune of Power, then found the defective Travel Stone.
    -- It *sounded* like the Rune of Power was applied when I clicked on the Travel Stone (the Rune of Power disappeared from my inventory), but the Travel Stone still doesn't work.
    -- I deleted the Dwarven Ambassador quest to start over. It vanished from my quest list, but when I clicked on Brandon to reactivate it, the DA quest was still there on his menu, starting with Part 2, not Part 1. In other words, I can't get a new Rune of Power. Tried this a few times. No correction.
    -- Funny thing is, whenever I do reactivate the quest (and it reappears on my quest list), that's when it disappears from Brandon's menu. If I delete the quest from my quest list, that's when it reappears in Brandon's menu, ready with Part 2.
    -- I even waited 24 hours to see if the game would "catch up" with the quest deletion. Nope.

    Basically, I can't restart the quest, neither can I move forward on it. Any suggestions?

    Also: aren't quest objects and quest NPCs supposed to have a question mark ('?') indicating their location on the new maps? None on mine. This is why I'm having difficulty with many of the new quests; I have to rely on DSO wiki for object/NPC locations.

    Please look into these matters. Thnx.
     
    Yogo likes this.
  2. trakilaki

    trakilaki Living Forum Legend

  3. Mindship

    Mindship Forum Inhabitant

    I can't believe I've seen some Lvl 50s already (what was the rush?); but yeah, I was surprised when the DA quest started giving me trouble.

    I figure Support has its hands full, given all the bugs that have popped up. Overall, I like the expansion, and this is the first serious issue I've had with gameplay since.
     
    Yogo likes this.
  4. Drakjula

    Drakjula Forum Greenhorn

  5. Mindship

    Mindship Forum Inhabitant

    It's been 11 days and the problem still exists. Just sayin'.

    --MERGED--

    19 days. Quest still broken.
     
    Last edited by moderator: Sep 19, 2015
  6. trakilaki

    trakilaki Living Forum Legend

    I solved that quest with my SW on TS, my ranger on Grimmag ... and last night i did it again with my level 45 SW.

    Not all objectives have question marks ... just like the turtle eggs quest ... you should find them on the map.
     
  7. Zamvel7

    Zamvel7 Active Author


    to finish it you have to do it from the beginning, and then the second point and so on, otherwise you wont be able to finish it.


    ammm in which server do you play, i am on tegan, if support can help i'll try to help you but your problem seems rare,
     
  8. Yours is showing as finished right through to, and including, (8/8)

    Check again.


    In future, please keep in mind that this section of the forum is for players asking other players for quest advice or for sharing one's exuberance (i.e. bragging) about having completed a tough quest. If you actually want assistance with a quest that has become bugged, the best place to seek that assistance is Support.
     
    MegaNuker likes this.
  9. Mindship

    Mindship Forum Inhabitant

    I'm on Agathon, but thanks for your offer of help, though I'm not sure what we, as players, could do with a broken quest.

    And so I did, hopeful, but the quest is still broken. It still starts me off with part 2.
    Understood. I hadn't really expected the problem to last this long, otherwise I would have from the start. In any event, thanks for your attention to this matter.
     
  10. trakilaki

    trakilaki Living Forum Legend

    It is not broken.

    [​IMG]
     
  11. MegaNuker

    MegaNuker Forum Ambassador

    Part 1/8 can not be deleted if you do then you need to contact customer support. You will not get the travel stone to activate. You toon can only get 1 rune of power. If the travel stone does not update just go into frog river delta and back out. Thus is for others that get stuck here also.
     
  12. Mindship

    Mindship Forum Inhabitant

    The quest has been fixed (kudos to Allogeneous). As of last night, when I checked the quest a second time, I was able to properly restart it, and so far everything's been jimdandy.
     
Thread Status:
Not open for further replies.

Share This Page