Bug Craft Squire's battle shield

Discussion in 'General Forum' started by Keryan, Jan 9, 2021.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
  1. Keryan

    Keryan Forum Apprentice

    When i put a blue squire's battle shield to craft an extraordinary item, the option don't appear. The craft is impossible since last update...
     
  2. silverseas

    silverseas Forum Veteran

    Are you doing "Rarity Upgrade" crafting?

    If yes, check that you actually have the recipe unlocked before you drop things on the workbench. If you don't have the recipe unlocked, check the Crafting section of your achievements.

    Also, check that you aren't trying to craft 4x shields, you have to do some "mixing and matching" (for example, 3x shields, 1x hat) to make the crafting go forward.
     
  3. Keryan

    Keryan Forum Apprentice

    [​IMG]
    Same level object. I tried many shield and the result is the same
     
  4. ргцт

    ргцт Active Author

    Can any moderators help this guy??? Or does moderators smoke crack & don't respond to players which needs help, like devs do aswell?
     
  5. silverseas

    silverseas Forum Veteran

    Well, I actually logged onto my DK and tried it out. It seems to be the shield that is causing the problem, because when I toss on any other combination of items, I am able to craft. The exception is the shield. So, it seems to be yet another bug.
     

Share This Page