Jewel of Enhancement

Discussion in 'General Forum' started by 9ndrei, Dec 26, 2018.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
  1. 9ndrei

    9ndrei Forum Connoisseur

    Hi,

    Got another question. I've been saving up 2 jewels of enhancement since.. forever it seems. I've decided to create 1 royal ruby and 1 sacred ruby with them. Thing is, I can't do it, or I don't know how. Here's what I've tried:

    - at the crafting bench, placed 2 sacred ruby + 2 jewels of enhancement (they are stacked and DSO never heard of split-stacking). Doesn't work.

    - same as above, but reversed the order. Doesn't work.

    - right clicked on the jewel of enhancement and left clicked on a sacred ruby. When right clicking on the JoE, an icon appears, but clicking the gems, does nothing.

    Can anyone help me with a solution?

    Thanks!
     
  2. Lazycrazy

    Lazycrazy Forum Apprentice

    Need to have 2 gems in your inventory, then right click on the jewel of enhancement and left click on that 2 gems, and voila.... you have new sacred/royal gem.
     
    navelko and trakilaki like this.
  3. trakilaki

    trakilaki Living Forum Legend

    You need 2 gems + Joker gem
    Same goes with runes + joker rune.
     
    navelko likes this.
  4. jeffzrx

    jeffzrx Active Author

    use it as you used the gem refiners
     
  5. 9ndrei

    9ndrei Forum Connoisseur

    Either I'm not understanding or you're not understanding. :) I think I already tried this and it's not working. Had 2 sacred gems in my inventory and 2 Jewels of Enhancement. I right clicked the Joker Gem (as you call them) and clicked on the 2 sacred gems. Nothing happens.
     
  6. trakilaki

    trakilaki Living Forum Legend

    You didn't say that way.
    anyway ... you need to learn "high tier gem crafting" ... meaning you will need to get the recipe if you haven't already.

    If you have finished the quest and you already have the recipe ... then you are doing it something wrong ... because it was working for me . I can't show you right now because TS is not working.
     
  7. ghostmagicus

    ghostmagicus Forum Pro

    Can you show a picture of joker u have? Maybe u try to use a rune joker on gems.
     
  8. 9ndrei

    9ndrei Forum Connoisseur

    This: http://drakensangonline.wikia.com/wiki/Jewel_of_Enhancement

    Well, I did. I mean I've crafted royals since the release..
     
  9. ΣMiwel

    ΣMiwel Count Count

    Right-clicked on the Joker Gem... Now, are you left-clicking the gems?
     
  10. 9ndrei

    9ndrei Forum Connoisseur

    Right click, left click, it doesn't matter. It doesn't work. I get the "You cannot refine this item" message.

    Any other ideas or should I go to support about this?
     
  11. Yogo

    Yogo Forum Great Master

    That's strange- you should be able to split the stack. Maybe that is why you are having problems? You are clicking on two JoE's instead clicking on one. Unfortunately I haven't got 2 or more of them to see if splitting works on them.Another thing: could you show a screenshot from the workbench showing that you have Royal Gems' crafting unlocked?
     
  12. 9ndrei

    9ndrei Forum Connoisseur

    Ok, this should be enough. There is no way of explaining this better. :)

    [​IMG]


    The jewels don't work on neither flawless or sacred ruby. I am not going to try it on anything else because I don't want to get anything else out of the 'Joker' jewels, so don't suggest that. I don't even want a flawless ruby, but I talked myself into trying it.
     
    Yogo likes this.
  13. Anyki

    Anyki User

    Hello @9ndrei

    I see only one Flawless Ruby and two Jewels of Enhancement. The refinement process requires two Flawless (or Sacred) Rubies and one Jewel of Enhancement. You will receive the error "You cannot refine this item" if you do not have the correct quantities of ingredients.

    Cheers,
    Anyki
     
  14. 9ndrei

    9ndrei Forum Connoisseur

    I'm sure I've tried it. :) But I'll try it again and screengrab the result. If it does work, the info on the jewels should really be updated. It currently says to do it at a craft bench.
     
  15. Yogo

    Yogo Forum Great Master

    Aye - it looks like you have been clicking on one Ruby instead of two. I think.
     
  16. stacker99

    stacker99 Forum Master

    You create a problem yourself. Just spare 2 gems from your stack then right click on JoE and next click on 2 gems stack. Voila.
     
  17. Kamil_Maziarz

    Kamil_Maziarz Forum Greenhorn

    I have the same problem. I right-click on JoD, left on the stack of 2 Sacred Onyxes and...nothing happens, no message is displayed. The JoE doesn't work on Sacred Rubbies ,Amethysts,Cyanites or Diamonds.



    [​IMG]
     
  18. callme0216

    callme0216 Advanced

    No worries , Hold Ctrl and separate the 2 Sacred Onyx from eachother , than right click on JoD and click on the 2 gems.

    Understandable why people have hard time with this since there is no logical way to explain why the system better like this when for ages you could craft them in the craftingtable..
    We have to get used to this and everything will be fine nextime.
     
  19. sargon234

    sargon234 Forum Demigod

    it does work, since that's how i crafted my second royal ruby§

    it seems this bug affects only some accounts

    How much gold do you have?
     
  20. 9ndrei

    9ndrei Forum Connoisseur


    Ok, what's wrong about what I'm doing here then?

    [​IMG]
     

Share This Page