map change connection problems - the sequel

Discussion in 'General Archive' started by fddkk9_gp, Jan 7, 2015.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
Thread Status:
Not open for further replies.
  1. fddkk9_gp

    fddkk9_gp Forum Greenhorn

    Saw the thread about the current connection problems, but couldn't reply because it was closed.
    I've been having this problem for 3 days now. Never had it happen before in almost 2 years. Now whenever logging in, changing maps, changing characters, I have to click Retry 1-10 times before I finally get in. I know it's not my computer because I tried the game on a computer I never played DSang on before and had the same problem. The response from support to clear cache, clean temp, etc. didn't help at all. I'm giving it a couple more days to clear up, if it doesn't, time to move on to another game. Hate to do that because I enjoy the game and I've spent so much time building my chars, but the game is pretty much unplayable right now.
     
  2. sebastian_fl

    sebastian_fl Count Count

    Thank you for the new thread. I hope they don't close this one until the problem is fixed so the players could share their thoughts, observation and just simply know the problem still exists or just got fixed.

    It is 4th day I have this issue. I have cleared everything and reinstalled everything more than 20 times. Support has got all the info and also log files.

    It is not the first time such an issue appears, if you google it there would be more than 20 threads, starting in 2012. None would have reasonable explanation.

    Looking into the log files, I would guess they have issues in both availability (operations) and the code itself.

    When the player is in a map, lets say Kingshill, and wants to change it, the program will do the following:

    1. disconnect from the server, from kingshill
    2. Try to connect to server again, to the same map, kingshill
    3. get the MapChange request/event, and connect to server again, to the new map.

    The connection may fail at the step 2 or step 3. If it failed at step 3 - you will see the map very briefly, for like 200ms before you see the error message.

    That is wrong and should be rewritten, there should not be step 2 at all.

    The other issue is the connection functionality. Most likely they have something like the following:
    in the code: user.connect(map, 15000); which is try to connect and wait 15 seconds. or 20 seconds or whatever. We all know that if it is going to connect it will happen in the first 2 seconds, or not happen at all.

    that logic should also be changed, instead of 15000ms wait time, there should be only 2000 or 3000ms, and instead of showing us 'Retry' button they should fire 'retry' event after 2-3 seconds and reconnect by themselves. Until it fails to connect lets say 10 times. then we could see our 'Retry' button.

    and finally the availability. something on the server is cutting connections which are considered too long. and that configuration is wrong as well.

    and there are lots of other unrelated errors in the log files, but let them focus on the connection.

    and of course, when you finally managed to get onto the map - there would be no lags and no issues, until you reach the other door.

    Moderators, please do not close the thread.
     
    Multi-Sev likes this.
  3. Multi-Sev

    Multi-Sev Forum Overlooker

    Everything you say makes perfect sense. The game code in a lot of places is dog-tired, old and patched together with chewing gum and dental floss. I hope a mod will pass along your suggestions to the dev team to give to the programmers for consideration.

    (Slightly OT, but...) I think something needs to be done about the DSO-client folder, too. I'm not a programmer, by any stretch of the imagination, but wouldn't it be possible to have sub-folders in there instead of a long list of 30,000-ish files? (Or whatever the count is now.) If nothing else, it might be a little quicker to delete the contents when necessary. It might have some other in-game benefits, too, but I don't know for sure.
     
  4. DesertKoala

    DesertKoala Forum Pro

    Java isn't really setup to optimize for a meandering directory structure. From Windows, go into Control Panel and select Java. Under Advanced settings, choose Show Console. When you launch DSO next time, bring up the Java Console window and press "S" to dump the environment variables. You'll see a cache directory setting. It is optimized to drop files into one directory. Yes, yes, I know there are exceptions but they come at a heavy performance penalty on your client.

    example:
    deployment.system.cachedir = C:\Users\Tregs\AppData\LocalLow\Sun\Java\Deployment\SystemCache
    deployment.user.tmp = C:\Users\Tregs\AppData\LocalLow\Sun\Java\Deployment\tmp
     
  5. This thread will stay open for now, but:

    1) Make use of this thread to clearly communicate the issue.
    2) Do not post general moans along the lines of "Oh, won't someone think of the children?!!!"
    3) Do not discuss responses from Support here. Discuss Support responses with Support.
    4) Stay on-topic. Do not use this thread to complain about how the Dark Heart torso makes your toon's butt look big
    5) Do not expect a resolution to the issue from this thread. The information will be collected and passed on.
    6) What are you still reading all this guff for? Get posting already!

    The information needed is as per my last reply in the closed thread.
     
    synje and DesertKoala like this.
  6. sebastian_fl

    sebastian_fl Count Count

    Allogeneous, thank you.

    Java has nothing to do with the issue we have, and the directory structure too. It could be easily optimized by using packages for resources, and there would be a major inprovement in the download time as we won't be required to re-dowload the entire thing, but still none of that will solve the connectivity issue.

    Is there any user from the past, who have had this issue in 2012, 2013, or in July/November of 2014 who was able to solve it by himself or with support from support?

    Those who have issues, could you please write results of the ping to the server you are on? just write in the command prompt (win+r -> cmd -> enter) 'ping grimmag.drakensang.com'. Replace grimmag with your server. I'm at 106-108ms. you? Also, did you update your windows recently with any updates?

    Those who have no issues, could you please write your ping results as well? is there anyone with 100+ms?
     
  7. Multi-Sev

    Multi-Sev Forum Overlooker

    Hmmm, well, it looks like the idea of sub-folders may have good and bad effects. Anyway, it doesn't have to do with connection issues so we don't need to discuss it further. Thanks for your replies, gentlemen. ~Sevasten
     
  8. avidgolfer

    avidgolfer Forum Greenhorn

    More on this, though i don't know how it will help.
    Firefox has a hard time getting past the login page. It frequently stops when accessing 'google.analytics' and won't load after that.
    IE on my Win7 system frequently displays "Cannot display page" when I first enter the DSO URL. It may take several tries before it gets to the login page, but it gets there.
    As for the client, whenever there's a new download, it gives an error, as if it can't connect to a download server. So the connection problems seem to be much more widespread than just changing maps.
     
    synje likes this.
  9. Dragonnns

    Dragonnns Forum Veteran

    Some ping results for sebastian_fl at 6:20pm Eastern Time (moderately busy)

    Agathon: 85ms
    Tegan: 96ms
    Grimmag: 112ms
    Heradur: 113ms

    I am located on the east coast of the US and normally on the Agathon server. I do not have connection issues going from map to map. I do have problems loading the forum (at least in the last few days) and I just now had a disconnect when in Kingshill starting the Defeat the Undefeatables event. When I was able to reconnect, my character had been relocated to a different part of Kingshill.

    Generally speaking my connectivity to the servers is a bit faster than listed above so maybe DSO is having an issue with response time on the server(s). I connect using the browser, not the thin client.

    I like using Opera as a browser but DSO doesn't work well with it. While investigating that, support told me that the game is optimized for use with Chrome, FWIW.
     
  10. Novadude

    Novadude Commander of the Forum

    What's your ping to Werian?
     
  11. Dragonnns

    Dragonnns Forum Veteran

    Ping to Werian is 114ms and to Balor is 113ms.
     
  12. bezryl

    bezryl Active Author

    soo still nothing being done to fix the problem been goin on since start of full moon event...Has everyone at BP abandoned the game or something? This is beyond absurd...
     
  13. sebastian_fl

    sebastian_fl Count Count

    Ok, will update on my issue. On Wednesday, I have had the ticked passed the L1-L3 or whatever they call it phases, and was forwarded to the Dev team, hopefully, for further analysis. I didn't receive any communication from Dev since then.

    Dev team have also received a link to this forum thread, as information source, so if anyone has anything useful - please comment. Please keep the thread clean of blah-blah but focused on the ticked. There are, actually, a couple of issues which are related:

    0. There is insane amount of errors of various nature in the log file.
    1. Thin Client black screen or crash - caused by general availability of the application and their CDN (content delivery network), either inhouse or provided by someone, but it has issues with either bandwidth or responce. This issue is not a blocker, you still can pass through after a couple of restarts. There are also other errors related to the facebook integration at the thin client start-up stage, but hopefully they are unrelated.
    2. Kingshill/Werian issues. They call it KingCity and PrinceCity. Both maps have checksum errors in the log file. It would be a bad idea to logout from there :)
    HttpNzStream: MD5 checksum error on cached file: 'httpnz://drasaonline-481.level3.bpcdn.net/cdndata/export_win32/db/static.db4'
    It could also mean that the upgrade which we had recently was not very accurate, either their Bulid was built with issues, or the provisioning of the new version was inaccurate or not in full. There are lots of options, it could be the other version, the other file completly, the other collation etc. This issue is not a Blocker, you could still login eventually and get out of Kingshill :)
    3. the Map Change. Or, like someone said here - it is impossible to even login into the app, or select the server, or select the character. It is actually the same issue, physically. It runs the same piece of code which is failing. and there are two-three flavour of that issue:
    a) availability. something is wrong with their data center, provider, routing, bandwidth
    b) inaccurate upgrade, non-integral build. It is possible if some parts where upgraded and some not, for whatever reason.
    c) the code itself. here is a cut from the logfile:

    The following is partially succesfull map change (character selection is also a map change).

    1) 2015-01-10 02:54:56 [INFO] DrasaClient: Received switch map command ().
    2) 2015-01-10 02:54:56 [INFO] RakNetClient::HandleDisconnectionByClient(): Connection to server closed (drasaonline-815-game-09-pub-01.bigpoint.net:30133, 178.132.242.32:30133)!
    3) 2015-01-10 02:54:56 [INFO] DrasaClientHandler: Actively disconnected from server (drasaonline-815-game-01-pub-01.bigpoint.net).
    4) 2015-01-10 02:54:56 [INFO] DrasaClientBase: Connecting to server drasaonline-815-game-01-pub-01.bigpoint.net:2190 ...
    5) 2015-01-10 02:54:57 [INFO] DrasaClientHandler: Connection to server established!
    6) 2015-01-10 02:54:57 [INFO] DrasaClient: Received switch map command (drasaonline-815-game-08-pub-01.bigpoint.net:30653).
    7) 2015-01-10 02:54:57 [INFO] RakNetClient::HandleDisconnectionByClient(): Connection to server closed (drasaonline-815-game-01-pub-01.bigpoint.net:2190, 178.132.242.24:2190)!
    8) 2015-01-10 02:54:57 [INFO] DrasaClientHandler: Actively disconnected from server (drasaonline-815-game-01-pub-01.bigpoint.net).
    9) 2015-01-10 02:54:57 [INFO] DrasaClientBase: Connecting to server drasaonline-815-game-08-pub-01.bigpoint.net:30653 ...
    10) 2015-01-10 02:55:17 [WARNING] RakNetClient::ReceivePackets(): ID_CONNECTION_ATTEMPT_FAILED, our raknetguid: 2785980636
    11) 2015-01-10 02:55:17 [WARNING] RakNetClient::HandleConnectionFailed(): Connection to server failed (drasaonline-815-game-08-pub-01.bigpoint.net:30653)!
    12) 2015-01-10 02:55:17 [WARNING] DrasaClientHandler: Connection to server failed (drasaonline-815-game-01-pub-01.bigpoint.net)!
    13) 2015-01-10 02:55:17 [WARNING] UISystem::AddWidgetToFocus(): trying to add widget 'ConnectWidget'twice, moving widget to top

    When you try to change map, if will fire commad 'SwitchMap'. It will disconnect you then and try to connect (line #5). In this case connection was successful. I would guess we are all fine, but what it does then is fire SwitchMap command again?! Disconnect you and try to - reconnect. Second time it failed.

    So you could see you are required to connect twice to enter the game. One failure and you are out. The funniest thing is that after first successful connection your characrer is already on the new map. and after you press Retry button, it will reconnect only once, and you are on if successful. There is a tricky thing here - since you are on the map (even if you are not, but program thinks you are after first success), the mobs start acting. When you finally get to the map, you might be hurt by someone, or Gorga might be in the middle of its action (map filled with the water). It might be causing the other side defects, like players locked in the maps blocking their teams from refreshing the boss.

    One more interesing thing, line 5th. You see the connection happened 1 second after you acted. I've seen it happening 2 seconds after, but not more. As you know, we are forced to wait 15-20 seconds before we could press retry button.

    My point is, Dear Dev, decrease the time-out to 3-5 seconds, and repeat the re-connect from the program, press that retry button instead of us 5-10 times.

    To sum up, there lots of issues to be fixed. I hope next release would be quality focused. I know what is quick-and-dirty approach, I know what is technical dept, I know what is legace code etc. But its time to pay technical debt off. I would code by myself if I could, but trust me, I would fire all my Devs with such a log file :)

    I will keep you posted on any developments, hopefully that issue will be addressed as I love this game and spend 3-4 years with it.

    --MERGED--

    guys, thank you on pings. I tried from Pensilvania, US - ping 106. Very stable. Florida, US - ping 140 - very stable. From Poland - ping 52 - very stable. I have tried from the station on provider site, with couple of gigabits available, - same result :)
     
    Last edited by moderator: Jan 10, 2015
  14. slice

    slice Forum Greenhorn

    Every time I try to log on I get these "Nebula 3" error messages about memory allocation and graphics. Can you please tell me why this is happening? For the record, yes I have been playing the game up to this point so it's not an issue with newly installed client :p. Also, before these errors started popping up, I have been getting a detected threat from my anti-virus saying something about Java obfuscation threat detected and it proceeds to delete a file (which doesn't affect ability to play the game). Any info on this would be greatly appreciated as well. Thanks in advance and I hope you can help with these problems. Thanks again! :)
     
  15. versrat

    versrat Someday Author

    I was playing this game fine yesterday for several hours. Today, the first toon I try gets kicked out with Error code 21 again. Trying to go from Ashraya into Ship Graveyard. Werian server.
     
  16. avidgolfer_gp

    avidgolfer_gp Forum Apprentice

    I live east coast US, but I use the Heredur server because there is not much PVP action on Agathon. My best developed characters are on Heredur, my chars on Agathon I use only when Heredur is not accessible (which happened a few times in the past).

    I have the "All connection attempts have failed" issue when I connect to Heredur. Here are various connection issues:
    - when first accessing Heredur server, from any browser or thin client, I seem to get disconnected because everything just stops loading. I have to do F5 several times before I finally get to the login page. Then similar issue after logging in. This is not all the time. Sometimes it all goes smoothly.
    - after logging in, it is a crap shoot as to whether or not I get a connection to the character selection page. Sometimes it goes there first time, other times I get multiple connection attempts failed errors.
    - After selecting a character, same thing, maybe the city loads first time, usually not.
    - map changes, same thing, at least one 'failed' error before I get in, usually more than one.
    - When I get to Thunder Crest or the last dungeon from THundercrest, I get Nebula errors. These seem to be graphic load errors, I suspect that I am losing my connection while graphics for the map are loading. I don't have this issue with other maps I access.

    Now for Agathon. When I log into Agathon, I don't have any of these problems. So first question I have to other players experiencing these issues is, where are you located? Are you in the US, Europe or elsewhere? Second question is, what happens when you access the other servers?

    I have not tried to access Grimmag or Weiran because I don't have chars there. Has anyone who is having issues with Heredur tried those servers?
     
    synje likes this.
  17. MegaNuker

    MegaNuker Forum Ambassador

    Agathon server.

    OK it is very very odd but here is some info of what I have experienced.

    If we let one person in the group go into the next private map (can take a long time) and they let someone know via /w (sometimes disconnected from chat server) everyone else loads up really fast just like normal. If two people load a private map at once they normally dc.
     
  18. synje

    synje Forum Apprentice

    Yes I live in east coat US as well and use heredur server. I have been having issues connecting to the game as well, through both the client and browser, for a few days now. When I am lucky enough to get into the game, I have problems switching maps. I get an all connections failed/retry screen. I have to click retry several times before the map will load.

    Everyone from Europe that I play with/talk to seem to have none of these problems.
     
  19. cntgetright

    cntgetright Forum Apprentice

    i live in US and use heredur server as well and i am having exactly the same problems every last one u mentioned i have as well including my friends in europe that have no issues as well as no issues in agathon.
     
    synje likes this.
  20. trakilaki

    trakilaki Living Forum Legend

    Like I said using VPN servers will not get you better gaming experience.
    The other thing is ... using them may get you banned. :D
    Of course you will have issues with such a long distance from the server to your PC. Distance itself is not the only issue ... but route, number of servers, knots ... etc.
     
    Last edited: Jan 11, 2015
Thread Status:
Not open for further replies.

Share This Page