Support Pixelated image after Windows update

Discussion in 'General Archive' started by Tilwin90, Dec 20, 2016.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
Thread Status:
Not open for further replies.
  1. Tilwin90

    Tilwin90 Padavan

    Context
    I just got a new ASUS laptop with an awesome NVIDIA GeForce GTX 1060 graphics card. As I installed DSO the graphics were absolutely stunning. I could play with maximum settings and not only were the textures crystal clear but the motion very very smooth.

    Change that lead to the issue
    An unfortunate Windows update occurred... And it lead to disaster.
    While the motion is just as clear, the textures and images everywhere are now quite pixelated. To give an example, please find attachment.
    [​IMG]
    Yep, this is exactly how the textures and images look in-game now.
    Other games work just fine. It's only DSO that is giving me this pixelated look.

    What I already tried
    I tried playing with various settings. Unfortunately I am not very experienced with NVIDIA graphics cards so I am not very good at handling the NVIDIA Control Panel.
    - From what I could tell I cannot add DSO as an exception because the executable keeps regenerating in Temp\AppData (why in the world it's done like this beats me...)
    - Since the motion is fluid, intuition tells me that it's using the dedicated graphics card.But I can't be sure.
    - Quality is much better if I switch to HD (1366x768) from Full HD (1920x1080) (but I would prefer of course to play my game like I initially could on the native resolution of my laptop with no quality problems).

    I already contacted support
    But since they are not technical guys, they could mostly just come up with ideas from the internet or what they intuitively felt I could try.
    Apparently since it's reproducing after a Windows update it is "a local problem" so nobody technical will do anything since "there's nothing to be done". I find it hard to believe it's "just my problem".

    So guys, I'm stuck now. And I need your help.
    Any ideas and suggestions from other fellow players are more than welcome.
    Thank you!
     
  2. 1) That's not exactly what was said
    2) Kindly do not repeat communications between yourself and Support outside of a Support ticket
    3) I believe you said it was a Windows upgrade, not an update *
    4) Did you contact your own language support team?
    5) The Support volunteers are not computer technicians. They are DSO game support volunteers. They are there to asist you with your DSO-related issues/questions. If you are having technical problems with your computer and you do not like the free advice given, then either figure it out for yourself or pay for a technician to check your system.

    * my misunderstanding there
     
  3. Tilwin90

    Tilwin90 Padavan

    1) Fair enough - did not include the whole context (though from point 2 it's obvious I shouldn't have). I'm sorry if it was understood that I have a problem with the support contact. He was actually really nice and helpful, though I am still stuck with the problem so I'm asking for suggestions from other fellow players. This is why we have this section in the forum after all, isn't it?
    Don't get me wrong, I'm trying to get my problem fixed here, doesn't really matter how :)
    2) I also didn't know this is a rule. I knew if I hadn't mentioned I had already contacted support I would most likely be redirected there. But I will be more careful from this point onward. I can go ahead and edit my message if that keeps things according to the forum rules.
    3) If we understand by upgrade going from a different version of Windows to Windows 10 then it was only an update. Might have mixed the two myself :) Again, let's keep this about the problem at hand.
    4) Not sure how this is relevant. Nevertheless, I used the in-game feature to contact support. So I suppose the game directed the email to the appropriate email address.
    5) I get that we are focusing again more on the channels of communication and the support team itself rather than the problem at hand so here are my remarks regarding this. Keep in mind that I am also involved in software development (though on Enterprise applications) as both a developer (technical person) and team leader. Hence why I have certain expectations regarding on how to approach this issue. I simply state this here because it might help understand my point of view rather than interpreting it as demanding a different status.
    - I am not unhappy with the response I get from the tech support guys. As I said, the answer showed involvement and helpfulness. I am not blaming the person for not being a "computer technician" as you call it.
    - I find it odd that there is no real technical support on Bigpoint's side regarding DSO. If we are talking about technical support, I expect a point of contact much closer to the technical guys involved with DSO. Again, might simply be a clash of terms here and how we name what.
    - Because the problem at hand reproduces only for DSO as far as I could tell, I would not refer to it as a technical problem with my computer in isolation. It feels unfair to put fully the responsibility on me as an end-user of the DSO application. See below.
    - With GTX 1060 being a newer graphics card and Windows 10 suffering changes, it is understandable that sometimes clashes can appear with the client application. This does not exempt a possible problem of compatibility with a particular client application (in this case DSO). THIS is where I would expect DSO support (though again, more technically involved persons) to show more interest in investigating this issue. After all, it is in everyone's best interest to find these potential issues and discuss potential fixes.
    - This post is a means of me trying to "handle the problem the best way I can". I don't expect people will have universal solutions since particularities can appear. If I were to be demanding and whiny, I would've continued to push this through the support team and that's that - I see no point in doing that on the forums. But that's not my intention!
     
    Last edited: Dec 20, 2016
  4. MikeyMetro

    MikeyMetro Forum Overlooker

    Have you tried the NVida GeForce forums? I have found this site useful in the past and it may be quicker then having your problem escalated thru DSO support to a DSO tech.

    Luck be with ye,
    Mikey,
    Tegan
     
    Tilwin90 likes this.
  5. Mesala

    Mesala Advanced

    You are not the only one with this problem, by default DSO client uses the integrated graphics card, that is why your image is pixelated, the only reason the game is fluid is because you have a high powered laptop with a decent integrated card. I am playing on Acer with core i5 and 940M Nvidia card. Up until a few days ago the game used the 940M card because I made it possible via the Nvidia Control Panel by adding the program and forcing it to use 940M card. Now it dissapeared from the control panel of Nvidia and the client once again uses the integrated graphic card. I am just fortunate enough that my graphics are not pixelated as yours are, they are just somehow less crispy and sharp, blurred out a little.
    I have tried resetting the thin_client inside the Nvidia Control Panel but to no avail. Even when you DO manage to force it to use the Nvidia card, the screen is just black, can't load the character selection screen.
    When your game uses the dedicated graphic card (Nvidia) you can see it by the small icon in the taskbar where the time is. The icon displays rainbow colors which means the card is being used by some application, and when you click on it, you can see the name of the application.
    When the game does NOT use the dedicated graphic card (Nvidia), but instead uses the integrated graphic card, that small icon is just gray.
    I am also on Windows 10 like you, and also I have a friend that has an Acer laptop too with 940M card, he also experiences the same problems, only difference is, he has core i3 processor and less RAM memory.
    I played with the different settings in Nvidia Control Panel like you did probably, but again I get stuck at the black screen, although I can see the rainbow colors on the icon which means dso_client uses the card but somehow is just unable to load it properly.
    You can try to set up the program inside the Control Panel by adding the link in Program Files, but it won't help you because the client uses the integrated graphics card again.
    I did not upgrade to Windows 10, and before it worked perfectly by simply adding the dso_client to use Nvidia card in the Nvidia Control Panel and forcing to use dedicated graphics card.
    If I come across a solution I will let you know, but I have to warn you, I have small hopes.

    Do me a favor, go into the Nvidia Control Panel, click on Menu and click on System Information and tell me what it says under Driver Information.
     
    Last edited: Dec 20, 2016
    Tilwin90 and Troneck86 like this.
  6. Tilwin90

    Tilwin90 Padavan

    Thanks for the suggestion mate. I will try the forums as well.

    Thanks for the tip with the rainbow square. I activated that now from the control panel and guess what, DSO runs under my NVIDIA graphics card all the time (whether I add it in the settings or not).
    I just got a new update from NVIDIA driver but to no avail. Still not working.
    I also tried upgrading all Intel drivers and there's nothing new to be installed.

    System information... hmm... Version 376.33, with API version 12 (DirectX 12.0), not sure what else you are interested in here. Probably driver version, right? :) As I said, I just updated today.

    Oh yeah, I just figured out the big update that caused me problems is the Windows 10 Anniversary Update (version 1607). I wonder if I should try a clean start on my laptop via Refresh Windows since I don't really have stuff on it anyway.

    Thanks for the help guys! Really appreciate it!
     
    Last edited: Dec 20, 2016
  7. trakilaki

    trakilaki Living Forum Legend

    Back then :
    Now ... when more than tested and confirmed ...
    I would never use Windows 10 because:
    - it is not of my liking
    - it is pure BS
    - I don't like someone controlling me
    - it has bugs ... glitches ... constant errors with different kind of drivers ... issues with most of the GPUs ... etc
     
    MikeyMetro likes this.
  8. Tilwin90

    Tilwin90 Padavan

    Heh, the laptop came with Windows 10... and I had absolutely no problems whatsoever in default factory settings.
    Then the silly update happened... took a long time to happen actually.
    And this is the result.
    What's puzzling me is that before this update DSO worked perfectly fine. No glitches, no low pixel situation, everything was smooth.

    Plus I'm curious for how long is Microsoft obligated to support Windows 7 before they force everyone to migrate to Windows 8/10, like they did with Windows XP.
     
  9. Troneck86

    Troneck86 Forum Great Master

    I bought an Acer during Black Friday with an i5-7200U and GTX950M. I have the same exact issues, I can't get the client to use my graphics card over the integrated one. If I force it, I get the black screen.

    The one thing I have tried and is just a sidegrade is use Firefox and force that in Nvidia control panel to use the video card. It loads the game just fine in the browser, but if I resize the screen or click Full Screen..black screen. This has me very sad since this laptop is more than capable of handling this game, but using the integrated graphics card in order to get the game to run at my native resolution kills my framerate.
     
    Tilwin90 likes this.
  10. Novadude

    Novadude Commander of the Forum

    I believe mainstream support for windows 7 has ended and extended support for windows 7 ends sometime in january 2020.

    https://support.microsoft.com/en-us/help/13853/windows-lifecycle-fact-sheet
     
    Tilwin90 likes this.
  11. Mesala

    Mesala Advanced

    SOLVED - procedure is this:
    1. step is to add the dso_client in Nvidia Control Panel
    [​IMG]

    Select High-performance NVIDIA processor. As for the settings below I left it untouched, but you can use whatever you want. Click Apply to confirm the changes.

    2. step is to find the Drakensang Online shortcut on desktop. Right click on it and choose Properties.
    Select Compactibilty tab and look the or the option highlighted below. It is turned off by default, turn it on.
    "Disable display scaling on high DPI settings".

    [​IMG]
    Confirm with "OK".
    3. step is to load the game and see if it works. There should be no more black screen, textures are sharp and the icon in the taskbar is now in rainbow colors. Your game now uses dedicated graphics card.

    Let me know Troneck86 and Tilwin90 if this the end of this bloody annoying issue.
     
    MikeyMetro, Troneck86 and Tilwin90 like this.
  12. Tilwin90

    Tilwin90 Padavan

    You, my friend, are a genius! I thought for a moment to try the compatibility setting but it never crossed my mind that check that setting out (especially since it's next to 640x480 screen resolution... go figure).
    Further investigation revealed to me that in Display Settings, for "Change the size of text, apps and other items:" setting it to 100% has the same effect of unblocking DSO. If I am not mistaken, prior to the update, it was set at 100% (not sure how it didn't bother me as the text is ridiculously small). I tested it after having a look at the Microsoft article here.
    I'm still surprised the setting propagates from the Client loader to the actual application (since it's separate executables), but I guess it works.
    Thanks a million for the help here. Now I can finally enjoy DSO.
    Maybe this workaround can be fixed long-term by the development team - if not, it would be a great idea to include this in the list of other problems that people run into (I would be surprised if other people on high resolutions don't run into this issue too).
     
    Mesala and Troneck86 like this.
  13. Troneck86

    Troneck86 Forum Great Master

    I wish I could like your post about 50 more times! It works like a charm and I can finally enjoy the game on the piece of hardware I bought to run it and my applications for work. Thank you so much!
     
    Mesala likes this.
Thread Status:
Not open for further replies.

Share This Page