Support is there a problem with Disaster to Master 7/9?

Discussion in 'Quests' started by jeffzrx, Dec 11, 2018.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
  1. jeffzrx

    jeffzrx Padavan

    i completed all the D to M quests but crafting supreme runes is still locked so i'm unable to do so
  2. Sprokkel

    Sprokkel Active Author

    I'm already stuck on disaster to master 2/9 and I have such a stupid plant and a bottle, already a few times went to the workbench but can not complete the quest.
    What a big nonsense all, am 4 to 5 hours busy with a quest that does not work!
    What can I do ?
  3. couda22

    couda22 Forum Commissioner

    You need the plant of the lowest rarity = obtained on painful mode. Plant of green or blue rarity can't be used to complete the quest.
  4. Sprokkel

    Sprokkel Active Author

    I have anacampseros of the lowest rarity and i bought a white/grey bottle, tried the workbench several times but can`t finisch the quest. It does not work.
  5. lovatic66

    lovatic66 Junior Expert

    All the missions are fine, it's just a matter of reading the descriptions well, I have to go in the nearby cities to continue completing the missions. :)
  6. Sprokkel

    Sprokkel Active Author

    The misions are not fine at all, i crafted 5 potions already and i read the descriptions well.
    but the quest wil not go on, i can`t complete it
  7. Rhysingstar

    Rhysingstar Forum Ambassador

    The descriptions are not well written, so some of them require going back to the quest giver to read how to get through them so you know which parts are needed.

    I got through all 9 knowing that they were poorly written before hand.
  8. Sprokkel

    Sprokkel Active Author

    By example, for this quest 2/9, i traveled to liar's lair on painful and on excruciating. I already have saved about 20 anacampseros plants and bought normal bottles, go to workbench to craft the potions several times.
    But i can`t finisch the quest, it keeps telling me to get anacampseros and a bottle but how many times i have to do that, it`s crazy and i`m losing my game pleasure this way.
    So, i`m still stuck on 2/9, quest does NOT work !
  9. ΣMiwel

    ΣMiwel Forum Ambassador

    Nope. Everything works as intended. You have to show the herb and the bottle to the quest giver. Read the task list of the quest.
  10. couda22

    couda22 Forum Commissioner

    Following video of crafting quest might help:
  11. trakilaki

    trakilaki Living Forum Legend

  12. lovatic66

    lovatic66 Junior Expert

    Mmm that strange, I already completed the missions 9/9 :)
  13. Sprokkel

    Sprokkel Active Author

    Thanks for all the help, especially the guide and the video show me that the quest giver does not ask me to show the Anacampseros (Herbs) and the bottle.
    So, the same quest is different for me than with you, so I probably get stuck on it because there is some sort of error on my quest 2/9.
    Worked all day trying to solve this but I can not continue with the quest because of this problem.

    Thanx to Bugpoint, what a disaster.
  14. couda22

    couda22 Forum Commissioner

    Try to reset the quest - delete it and then accept it.
  15. _Baragain_

    _Baragain_ Living Forum Legend

    That is your mistake.
    You also need to farm an Anacampseros while you have the quest.

    Fortunatly, it is only 2/9 that is really stupid, but here is a check list.

    1. Enter a scaling map in the Duria Region between Painful and Fatal
    2. Farm an Anacampseros plant in Painful or Excruciating. As long as it drops 2 or more, you are good. If it drops one, find a second Anacampseros. Previously farmed Anacampseros will not count.
    3. Go back and show him the Anacampseros.
    4. Buy the bottle.
    5. Craft the potion.

    Stupid question, but did you right click the crafting book that you got from the quest?
  16. Kiwigal1244

    Kiwigal1244 Active Author

    I travelled to Stonekeep entered, checked quest, it was ticked as completed, then returned, bought the cheapest bottle, and crafted items.
    Quest completed. Travelled to RCC for the next. Not sure if that was meant to happen .. but hope it helps
  17. Akageshi

    Akageshi Forum Duke

    I finished the entire quest line without getting stuck once. I bet most people's problem with these quests emerge from not reading what they're supposed to do.

    Perhaps the only information that is not provided is the fact that once you finish the Kingshill part, you have to go to Resistance Command Center, then to another urban area, etc. This is, I think, not clear from the dialogues. Yesterday, people kept asking me where they are supposed to go. I would answer: Just visit the towns in the same order you would first visit them playing the main story.
  18. jeffzrx

    jeffzrx Padavan

    my problem isn't completing quest 7/'s not there to complete LOL
  19. Dragonnns

    Dragonnns Count Count

    I would also suggest using Quest Guidance on some of these. The guidance seems to take you to the right place regardless of the instructions.
  20. Kerensa

    Kerensa Forum Greenhorn

    my problem also isn't completing quest 7/'s not there to complete.