Jewel of Enhancement

Discussion in 'General Forum' started by 9ndrei, Dec 26, 2018.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
  1. trakilaki

    trakilaki Living Forum Legend

    This one is from TS, taken few weeks ago

    [​IMG]

    It was working.

    Now ... since TS is not working ATM I couldn't test it there again ... and i don't have joker gems on my ranger.
    I made a search of my other live server characters and I found one joker gem. Even if that was the only joker gem i had I spent it for testing purposes (and screwed up the character since those were only sacred gems too).

    [​IMG]

    so ... yeah it is working

    [​IMG]

    It doesn't take gold for the crafting ... but it could be like the workbench and the premium discount. You have to have enough gold even if it takes only amount of gold with the discount calculated in the crafting price.
    I think the joker rune was taking gold for crafting when I was testing at TS , few weeks earlier .
    Who knows ... maybe players with premium can craft it for free .
     
    _Baragain_ likes this.
  2. 9ndrei

    9ndrei Forum Connoisseur

    Nice, but that doesn't help my case now, does it? I'm trying to do the same exact thing with rubies and it doesn't work..
     
  3. heror

    heror Forum Baron

    There is that thing called support m8 traki cant do Magic as he is just a human being ( on top of being chuck noris god :D)
     
    Last edited: Dec 29, 2018
  4. Yogo

    Yogo Forum Great Master

    Sorry to ask, but just in case- how much gold have you got while attempting using JoE on Rubies? Do you use Premium/ Premium Deluxe? If you just make sure you have the sufficient amount of Gold needed to craft Royal Ruby during usual crafting using Workbench? Yes, yes - using the JoE will not use any gold but can you just tell us if you have such amount of gold while attempting to use JoE? So to summarise:

    - have you got Premium?
    - have you got Premium Deluxe?
    - how much Gold have you got while attempting to craft the Royal Ruby using JoE? ( for instance 210 Gold in the case of Premium etc.)
     
    Last edited: Dec 29, 2018
  5. 9ndrei

    9ndrei Forum Connoisseur

    Had about 2k gold. :)

    Mate, if you look back at the thread, you'll see me saying "so this means I should contact support"? But some nice people had alternatives that I wanted to try.. so I did. After I've exhausted everything, I'll take this to support. But thanks for letting me know that there's that thing called support. Your input is greatly appreciated.

    Oh, and by the way.. that wasn't a shot at Traki. You just assumed, wrongly, that it was.
     
  6. sargon234

    sargon234 Forum Demigod

    it seems to be a bug that affects some characters, i have one guild mate who has the same exact problem and can't craft a royal ruby

    she used the same standard procedure: right click on jewel of enhancement and left click on the 2 sacred ruby, but nothing happened
     
  7. silverseas

    silverseas Forum Commissioner

    Out of curiousity, I took out my Jewel of Enhancement and used it on some Amethysts. It worked just fine and didn't cost a single coin to craft.
     
  8. Osote

    Osote Forum Greenhorn

    I initially tried ruby, ruby, jewel in 3 slots in inventory and when clicking it gave the error about not being able to refine. When I dragged one ruby onto the other to make a stack of two, as shown in trakilaki's post above, it worked for me.
     
  9. 9ndrei

    9ndrei Forum Connoisseur

    Ok, so the thing fixed itself. I didn't do anything wrong, but it was a DSO bug. How it got fixed? Well, I opened up the Big Present in Kingshill, got another Jewel of Enhancement, stacked it wit the other 2 I had, the ones with issues, and now all three of them work.

    Used 1 JoE on 2 stacked Sacred Rubies and the magic happened.
     
  10. trakilaki

    trakilaki Living Forum Legend

    I know why is that.
    Some items didn't convert properly.
    Here is an example of essences not converting properly in the early TS version
    [​IMG]
    [​IMG]
     
  11. 9ndrei

    9ndrei Forum Connoisseur

    That's the most likely scenario. :) I'm just glad I got it to work in the end without jumping through 1000 hoops with support.
     
  12. Tr03p

    Tr03p Forum Greenhorn

    Hi, I had the same problem. Here is the solution. If you open the workbench you cannot use the Jewel of Enhancement. Just put two identical gems in your inventory, click on the Jewel of enhancement, then on the gems and the two gems become 1 of a higher level. Good luck!
     

Share This Page