Level requirements doubled?

Discussion in 'Questions about Getting Started in the Game' started by slapyermammy, Apr 23, 2021.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
  1. slapyermammy

    slapyermammy Forum Greenhorn

    I have 2 level 47 characters. I am currently in the Stillwater area. When I logged in today and tried to enter dungeons the game says that minimum levels to enter are 81 or more. Is this a game glitch or what?
     
  2. Anyki

    Anyki User

    Hello there,

    The minimum level to enter on Normal difficulty is level 41. If you're seeing level 81, you have the difficulty slider set to "Bloodshed" difficulty. Click on the arrow to enter the dungeon, and take the difficulty slider in the middle and move it back down to Normal.

    Cheers,
    Anyki
     
  3. slapyermammy

    slapyermammy Forum Greenhorn

    Well that worked! Thanks a million!
     
  4. Anyki

    Anyki User

  5. TwiliShadow

    TwiliShadow Count Count

    That slider is _way_ to easy to move when the window pops up. There needs to be a full 1 second delay after the window opens before you can "effect" anything.

    I can't count the number of times that I've opened a map window and because of where my mouse WAS and that the window opening was faster than me releasing the mouse, that the slider was grabbed without a mouse _press_ but responded to the drag and mouse release and thus changes the difficulty selected.

    A simple 1 second delay on open before accepting a mouse input would completely solve everyone's "erroneous slider behavior".

    Same as toon movement has to stop for almost a second before you can actually initiate a mount action.
     
    bibere likes this.

Share This Page