Support MAC Client Technical Support

Discussion in 'Technical Support' started by Biztart, Dec 7, 2013.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
  1. ipaTcH

    ipaTcH Forum Apprentice

    Hey guys.

    Dear Drakensang Team PLEASE before you release a new update or feature TEST it on a Mac with RETINA screen !! I just downloaded 201 and omg it is so bad.

    2 very annoying bug :

    1, On retina screen the cursor is 2x bigger than normal, it's totally unusable, my cursor has the same size as my character on screen... like what the hell ? why do you allow us to change the cursor but not the size of it ? Please add a size change option for us it's 2017 every screen (over fullhd) which has 2x more pixels will have this error. And yes you can't play with a huge cursor i can't see the mobs i'm hitting lol....

    1.1, The game will automatically add the new cursor and with the new cursor the fps is under 5... without the new cursor the fps is back to normal... ?????? you guys really messed up this cursor...

    2, If the Chat window is open or closed the fps starts to drop slowly because people write there, i need to open the chat select the group or clan tab where only a few messages are and then close it so i dont lose fps with time. As the chat grows less fps you have. Like what the hell is this ? After 30min when the chat has like 100 lines to messages my fps drops by 15 and it continues every time i have to change to clan or group tab to fix this... pretty annoying

    With the new update the game is totally unplayable i just can't do anything and this happens on all computers which have bigger screen than fullHD... i tested it on 3 computer...

    [​IMG]
     
  2. Yogo

    Yogo Forum Great Master


    1. The pointer is big but it looks great- I have no issues with it and I'm also on Retina display. Really happy with the pointer- I can see it now in all locations properly and I do not agree that it somewhat covers the mobs I'm killing. Now I have to admit that adding an option of scaling the size of the pointer would be a proverbial icing on the cake.

    2. As far as fps issues are concerned- I've only noticed the drops in Fps while standing idle on the map- once in motion fps goes back to normal. Also you may be having fps drops because your DSO content hasn't loaded fully yet and you are playing with the minimum of around 88-200 MB data loaded. I don't know mate- it all looks good here- on iMac with 27'' Retina display - the game runs smoothly and I have no issues.So far - so good.

    peace out
     
  3. ipaTcH

    ipaTcH Forum Apprentice

    Game is totally loaded, and yes i noticed too if i stand still i get fps drops but for me if a player appears on the screen i get again 5 fps until he leaves. it's insane :/
     
  4. Clamdip

    Clamdip Forum Greenhorn

    Just updated to newest patch too. 2017 21.5" iMac with a 4k Retina display. Game is fully downloaded. Having same issues as above. Very, very jerky with low FPS in urban areas. Lowered settings to either low or off, made no difference in FPS. Maddening, indeed.

    The cursor issue is a problem too. It is way too big, and covers many baddies I'm trying to kill. Even when set back to the old-style pointer, the cursor is too big. An option to scale the cursor would be nice.

    Please fix the FPS issue, and consider letting us scale the cursor if you intend on keeping it.
     
    ipaTcH likes this.
  5. Yogo

    Yogo Forum Great Master

    I may have found a temporary solution for Mac's 27in 5K Retina display users. While in urban area, change to window mode by clicking on Toggle Full Screen in the top right corner - you should see improvement straight away - I mean the char should move, walk, run smoothly ; you can then switch back to full screen and you should enjoy the same smooth performance:) Try it- it works for me every time:)
     
    Last edited: Nov 28, 2017
  6. Saved_81

    Saved_81 Forum Master

    I came across this thread and I haven't readen everything it was written before but definatly the FPS issue isn't only a "MAC problem".
    I don't have a MAC but I'm getting a LOT of problems since the last update.
    I keep having a lot of fluctuations in the FPS (later I'll add screenshots and eventually a video too).
    Any time I alt+tab I got impressive FPS drops which, in reality is impressive stuttering.
    I've triple checked the GPU usage and VRAM usage and I was @30% GPU usage and 15% VRAM (so definatly not a graphic card bottleneck infact, normally I play @ 75fps with max settings).
    The FPS drop isn't real as well because I've monitored it and it resulted to be a stuttering problem not FPS drop because even when I got low FPS I never drop under 20-25 FPS (which would result in a decent game experience, in this case I have severe stuttering instead which makes the game barely playable).

    Other than this, after several minutes of this mess the game crashes and i get a nebula3 errore referred to vertex mapping (asap I'll post the screenshot) so I though it was a Vsync related problem.
    I've then disabled Gsync and forced frame limit via Rivatuner.
    This solved partially the stuttering when alt-tabbing but still I get random (very frequent) nebula errors related Vertex mapping.

    Lowering the details never gave any benefit.
    I've then tried to lower the FPS via drivers but, also this, never gave any benefit (btw DSO isn't listed in the optimized nVidia drivers config while it was listed drakensang which seems odd since they should share the same graphic engine I used Drakensang settings).
    The only thing that "fix" the problem is to try to reduce to window mode and then to full video mode several times as Yogo suggested.

    I've asked to my guildies how was the game experience and it resulted that, the better was the GPU, the worse were the perfomance since the last update.

    Posted a screen of the error

    [​IMG]

    last update
    deleted temp fold and re-downloaded the Whole game seems have fixed the issue.
    Now I don't have stuttering when alt-tabbing, no more need to play with window mode and no crashes in 1h gameplay.
     
    Last edited: Nov 28, 2017
  7. Shine2

    Shine2 S-Moderator Team Drakensang Online


    Hello friends, all of the above-mentioned issues have been reported through appropriate channels.Thank you for your input;

    kind regards.
     
  8. balaban49

    balaban49 Forum Apprentice

    friends can not enter the game client is not loading, is there a problem?
     
  9. Ammerling

    Ammerling Forum Apprentice

    Everything is OK, event triggered, no problem.
     
  10. 9ndrei

    9ndrei Forum Connoisseur

    Got a few things to say.

    1. It's a lie that the server issues appeared when the DTU event started. It actually started way before, with huge lag spikes. The only difference is that now it's a lot worse.

    2. Are you planning on extending DTU for a few days? It's unplayable. At least once per hour everyone gets lags of 500-900ms.

    3. Will we get anything back? You know, things like spirit stones and crosses, since there are a whole lot of them lost because of the server issues.

    Thanks
     
  11. Yulka1980

    Yulka1980 Forum Greenhorn

    Same problem for me, new client is not loading!!!!! Deleted the temp data a few times. Downloaded from web a few times. No way the new client loads. I m XP user could that be the problem?

    Any information will be appreciated. Sorry fot the english, not my mother language.
     
    stasis likes this.
  12. CzSamurai

    CzSamurai Forum Apprentice

    me too, same win XP, same error during updating of client.. please repair asap..
    [​IMG]
     
    stasis and Григорий like this.
  13. akostorrao

    akostorrao Forum Apprentice

    Im a mac user, dosent load too...
     
  14. ===_*_===

    ===_*_=== Forum Greenhorn

    same problem here, I'm a mac user, too.
     
  15. akostorrao

    akostorrao Forum Apprentice

    Hi, latest releases gave me no problem on loading them.

    Im a mac user, normaly i made download of release in 1 minute, but today is taking me 1 minute to download 0,2 mb. its 1600 mb to download so wil take me an eternity...

    Anyone knows whats the problem? on my other pc (win xp)
    , no problem on loading update.

    Can anyone help?
     
  16. ===_*_===

    ===_*_=== Forum Greenhorn

    I have exactly the same problem. I hope they get it fixed soon.
     
  17. Yulka1980

    Yulka1980 Forum Greenhorn

    I posted somewhere else. I have the same problem and some of the posts i have read from other countries the same. We are all Win XP users. I think they have decided to give us a kick on our backsides and say bb to us. If so I have 50 days of Premium left, would like my money back. Sorry for the english, not my mother language.
     
  18. vannick242

    vannick242 Forum Apprentice

    Release 228- I have problem, client is not loading.Why???
     
  19. trakilaki

    trakilaki Living Forum Legend

    Are you all using Win XP and Mac?
     
  20. vannick242

    vannick242 Forum Apprentice

    Yes.
     

Share This Page