Support MAC Client Technical Support

Discussion in 'Technical Support' started by Biztart, Dec 7, 2013.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
Thread Status:
Not open for further replies.
  1. You don't need Java for running the client version of DSO. The OS needs to be at least OS 10.10 (Yosemite).
     
  2. onelove

    onelove Forum Apprentice

    El Capitan OS upgrade caused crash bro, any suggestion?
     
    xazmcv likes this.
  3. Zamvel7

    Zamvel7 Active Author

    @onelove
    once I had the same problem not with DSO,the solution i see it's to downgrade your system n.n
     
  4. xazmcv

    xazmcv Forum Greenhorn

    I played yesterday no problem. Today, log in name and password, next screen where you select the server is black.
     
  5. Darwarren

    Darwarren Count Count

    Had the same thing with a Windows PC. All my web browsers got computer talk, instead of the DSO homepage.
    Told support. An hour later all was fixed.
    ??
     
  6. It was an issue at BP end. It was not Mac-specific - all servers were affected.
     
  7. blitzcragg

    blitzcragg Forum Apprentice

    I couldn't log in yesterday, got nothing but black screen. Tonight, i can log in and get my choice of servers. When i choose the server that i play on, i get a screen that says
    ---------------------------
    DRO Client
    ---------------------------
    Failed to launch client.
    ---------------------------
    OK
    ---------------------------
     
  8. JODAN01

    JODAN01 Forum Greenhorn

    Sir how can i fix the Client because it say "failed to lunch client" how can I fix it? Please Help me..
     
  9. DracoDreamDragon

    DracoDreamDragon Forum Greenhorn

    my LvL 14 DragonKnight has stoped i can move and buy things and when i'm doing a quest nothing happens and i get killed and have to start over and the same thing stills happens working but the othe three are working just fine can you see what the problem is with my Dragonknight and let me know
    thank you DracoDreamDragon
     
  10. Bullballz

    Bullballz Forum Greenhorn

    I can't get to the game or download the game on my iMac since the last patch. What's going one

    -- MERGED --

    sorry, what's going on?
     
  11. To access the Test Server from the Mac Thin Client:

    Launch the terminal.
    Go to the application directory :
    cd /Applications/drakensangonline.app/Contents/MacOS/

    Run command with the "enter" key
    Start the client with the argument " -stable "
    ./drakensangonline -stable

    Run command with the "enter" key


    Note: I stole this off the French DSO Forum. So, if it doesn't work or, even better, it turns your glittery over-priced lap-warmer into a pretty paperweight, please send all caustic correspondence their way.
     
  12. AnnaConda

    AnnaConda Someday Author

    i have a Macbook Pro Retina 2012 using OSX El Capitan. Since yesterday's update of the game my level 22 ranger (Elmfist) cannot use his Duria Longbow. In both the Wild Forest and the catacombs dungeon even facing enemies he can move but cannot shoot. No idea what to do about it.
     
  13. rocket54321

    rocket54321 Forum Greenhorn

    when I click the download link it goes to the regular windows download page and downloads "dro_setup.a087197847bd334b42b7ebd4eb713597.exe", I can't find a mac-friendly download or download walkthrough.
    running OSX 10.10.5
    mid-2011 mac desktop
    intel i5 2.5 GHz
    4 GB memory

    I'm new to this game (this is my 1st forums post), any help is appreciated.
     
  14. Michelllevo

    Michelllevo Forum Apprentice

    Why cant i DL .dmg file anymore i only get .exe when i dl?!
     
    Last edited: Aug 10, 2016
  15. ElRockeye

    ElRockeye Forum Greenhorn

    Website not letting MAC users download dmg. only exe. CANNOT play game.

    OS X El Capitan
    2.5 GHz Intel Core i5
    16 GB 1600 MHz DDR3
    Intel HD Graphics 4000 1536 MB
     
  16. uenkai

    uenkai Forum Apprentice

    Yes problem same for me Mac user.

    I can't download required data just like usual.

    It shows drasa_online_client quits unexpectedly.

    Tried to download new set up via DSO home page and after downloading i can't open the file and install as it is .exe

    It is really frustrating and unfair for us Mac user as players out there are grinding for this long waited event.
     
  17. Michelllevo

    Michelllevo Forum Apprentice

    Ye i tried to re install too but no.

    FIX IT PLS.
     
  18. Brunken

    Brunken Forum Apprentice

    Same problem with download for me, getting exe files... When I ran the client it updated but now it crashes at start, if I choose ignore it continues running but downloads at a pace of 0,1 mb/30 sec. Very frustrating so I thought I would reinstall.

    System:
    8 GB RAM, OS X El Capitan 10.11.6, Intel Iris Graphics 6100 1536 MB (which is superior to Intel HD 4000 from what i read so requirements shouldn't be the problem)
     
Thread Status:
Not open for further replies.

Share This Page