Bug Possibly.

Discussion in 'General Archive' started by DocwhiskyTS, Nov 11, 2017.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
Thread Status:
Not open for further replies.
  1. DocwhiskyTS

    DocwhiskyTS Forum Apprentice

    So I have been playing my lvl 52 DK on TS... A while back, this toon was bumped from 30-ish to 50 when the Desert expansion was being tested. I went back and have been completing all the skipped quests. So here is my problem.

    I got to the quests "Balance of Life and Death" and "To Life and Death" I have done all quest requirement's, have the Crystal Skull for Death and the Fruit of Atrya for life, but when I enter either map, It will not let me place either of these items in there respective Altars.

    Since My toon was bumped, is this quest unfinishable now as I have access to Hiraja???
    Its hard to tell, but it looks as though the altars are active. If this is the case, what about the quests in death that come from the ferryman... since this quest is turned into him, If I cant complete this quest, then the whole quest line dies.

    Is the only option here to cut my loses and move on??

    Thanks, Doc.
  2. trakilaki

    trakilaki Living Forum Legend

  3. DocwhiskyTS

    DocwhiskyTS Forum Apprentice

    Hi Traki :)
    Thank for reply. I double checked the Wiki yesterday just to make sure I was doing it right (before I posted :cool:). As far as I can see, I did everything required.
    I think because my toon on TS was bumped, so I could have access to Hiraja, some quests were "skipped" or "auto completed" so I could enter Hiraja without having to complete them first.
    Since then, I have been going back trying to complete all those quests to help build my toon. lvl 50 DK with lvl 30-ish gear and gems doesn't get around in PW very well .... lolol o_O

    As I said in the original post.. it does "look like" the items are already on their respective altars in each map. (bad news for me I thinks) and I'm not positive about these being some of those quests that need to be finished BEFORE you can enter the Desert maps, but that's the only thing I can think of.

    I will try again today... if I cant finish, then I guess its time to move on to other lands...

    thanks, Doc.
  4. MikeyMetro

    MikeyMetro Forum Overlooker

    Hey Doc,
    I have a few of these bumped up lvl 50s. Notice that the first time you go to Yaltepetl that the quest Saving the World Heart 2/2 is already available. Checking the compendium will show that Saving the World Heart 1/2 (swapping the skull and fruit) is already checked off. So yeah, all evidence points to this was something that was done to these artificially inflated toons.

    Still I do so enjoy wasting time on pointless endeavors so I used a couple of these toons that had not done any Nahu quests yet to see if there was any way thru this. Nope :D Along with not being able to do that quest the side quests in Cradle of Death are also not available.

    Time to get your Honorary Jullov, Kill Balor and move on :cool:

    Luck be with ye,
    DocwhiskyTS likes this.
  5. trakilaki

    trakilaki Living Forum Legend

    My SW (Grimmag server) is "artificially inflated toon" as well ... she was a "victim" of the Dragan event :)
    I am keeping it with only one purpose ... to finish some quests that need updating at Wiki (Lor'Tac quests). So far i was able to finish ^ both quests few weeks ago.
    Before the expansion came to live servers many quests were different ... Saving the World Heart was 3 parts quest

    They changed it (and some other quests) before the expansion went live ... I had it already finished with my TS SW so I couldn't take it again ... that is why I am doing Lor'Tac quests with my other SW. So far she has no problems solving the quests.

    Doc try to delete and take the quest again it can fix the issue ... or approach closely to the objects. The altar was bugged in the past and was not approachable but they fixed it.
    DocwhiskyTS likes this.
  6. DocwhiskyTS

    DocwhiskyTS Forum Apprentice

    Thanks Traki and Mike,
    Unfortunately, Like Mike, I just wasn't able to make either altar take the item ... Tried several times on both altars, tried mounted, unmounted, tried coming at them from different angles, etc. etc. Eventually just deleted those 2 quests just to get those 2 inv slots back.
    I will try taking them again at some point, see if it happens again.

    Yup, already moved on... Already burned thru almost all the desert quests... now need to find some help killing the Genie in Treasure cave ..sad really, Almost all "available" quests are done... just turned lvl 53. gonna be a loooooong push to 55 lololol.

    Thanks, Doc.
Thread Status:
Not open for further replies.