Quest Problem

Discussion in 'Quests' started by ItzStam, Feb 14, 2019.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
  1. ItzStam

    ItzStam Someday Author

    I have a dwarf, lvl 44 in server Grimmag. I have this quest called Operation Ophidion, in which there is a step that says to "Steal the chest from the workshop foreman". I click on it for the guidance, and leads me to stalgard. But as soon as i get into the map, it says "Quest guidance cannot find anymore goals. Please re-enter the map". And this has happened more than 10 times that ive tried... I tried teleporting through the travel stone, i tried alone and with group but nothing. This quest is really important to finish, as it is a yellow quest which means i have to complete it to continue the game and of course level up faster... Please help me out
     
  2. MikeyMetro

    MikeyMetro Forum Overlooker

    That is because the chest does not appear until you have killed the technicus foreman. The guidance turns off when you enter because it is for the chest and not the foreman.

    Just explore a bit. You'll find him ;)
     
    trakilaki likes this.
  3. trakilaki

    trakilaki Living Forum Legend

  4. ItzStam

    ItzStam Someday Author

    but i have killed every single monster in stalgard and havent found this technicus foreman...

    -----MERGED-----

    nevermind, i deleted the quest and redid it again. Thanks for the help tho
     
    Last edited by moderator: Feb 15, 2019
  5. Shine2

    Shine2 Board Administrator Team Drakensang Online

    Hello ItzStam, in future , please use Edit option to add to your existing post instead of writing 2 consecutive posts one after another. Thank you. Now - about the quest - you canceled it and started the quest again - did you succeed to complete it then?
     

Share This Page