Feedback Release 164

Discussion in 'Discussions on Current Topics' started by teddy.bear, May 2, 2016.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
  1. Mal3ficent

    Mal3ficent Guest

    Known issue, it will be fixed with the next release.

    Morinphen likes this.
  2. Red_Jaeger

    Red_Jaeger Junior Expert

    Another issue that I'm having is that even though I change the hotkey "X" for essence swapping to another key, it resets itself every time I log in.
  3. Rhysingstar

    Rhysingstar Forum Ambassador

    Wasn't this supposed to tell us if we missed a quest? Maybe an unchecked box or something?
    Morinphen likes this.
  4. gun

    gun Forum Great Master

    Confirmed Red_Jaeger.
    Changed the hotkey for swap essense with "T".
    Relogin the hotkey back to "X".
  5. MikeyMetro

    MikeyMetro Forum Overlooker

    I'll apologize for this one since I seem to have started this rumor with my post in the preview thread. Turns out it was a case of wishful thinking. I you skipped a quest or leveled up past the point that the NPC's "!" turns off things are the same as before.

    Luck be with ye,

    //Edit// If the progress bar in the compendium worked (new content = bugged content. same ole, same ole) Then it would be easy to see if there was a skipped quest. Still not near as user friendly as it ought to be.

    Also, I just finished pouring my high level toons into Werian for the new quests there. Interesting enough the "!" does show regardless of level. (I have no Idea what's going on with my lvl 43 in RCC in regards to this.)
    Last edited: May 10, 2016
  6. Rhysingstar

    Rhysingstar Forum Ambassador

    I get the part of turning off the "!" but what's the point of showing me all the quests I have completed if there isn't something to show me if maybe I missed or skipped one?
  7. Universeea

    Universeea Advanced

    Only this game I get errors.
    Hope I can get back into the game soon so my premium doesn't go to waste...:mad:
  8. _Baragain_

    _Baragain_ Living Forum Legend

    That's an easy one. You can delete the entire DSO Client folder per the troubleshooting guide if you want, but then you'll waste about 1GB re-downloading the game files over the next couple of days. Or, you can delete just the "dlcache" folder inside the DSO Client folder and only have to re-download 24.6 MB the next time you log in. Just make sure that the DSO exe isn't running hidden in the background in your task manager under "processes."
    Minota likes this.
  9. Universeea

    Universeea Advanced

    Where is that? I checked roaming folder and the DrakensangOnline folder. :confused:
  10. _Baragain_

    _Baragain_ Living Forum Legend

    Press the start button and type %temp% and hit enter. That will put you in a hidden directory that wouldn't be found via a regular search. That too is in the troubleshooting guide. Here is the direct link to the troubleshooting post in question.
  11. Universeea

    Universeea Advanced

    Woweee thanks so much i'll be using that guide in the future TYVM!
  12. Mesala

    Mesala Advanced

    There is an unusual bug when you go port through the arrow icon, game stops, you see brown screen, you can even see what others are typing on chat, but you can't do anything, except shutdown client and open it again. Oh and I noticed new nebula error during gameplay, and this one was really long. And there is also a graphical glitch when you use DK skill Charge on steps, somehow you end up inside the stone lol (you literally dissapear inside), crazy stuff.

    Thank you for the toogle essence and hats off to the designer who designed the new Obsidian wings, they look great.
  13. LordDefiant

    LordDefiant Forum Apprentice

    Essence toggle is really good and its sad that it took it so long to implement it in the game,, now auto essence pick up aint working i turn it on in menu but it wont auto collect it, now what about Nightmare “Blazing Inferno ? when will we get it? i thought it will come with r164
  14. Ash

    Ash Advanced

    haha. Anyone else find it strange that the jokers and clover guy aren't at the fairground?
    I actually thought they would place the fairground in that area, bottom left. Made sense since jokers were there, plus not requiring an epic mount and fairy wand to get there in reasonable time. ;)
  15. dkarl

    dkarl Forum Duke

    For me, it's the western statue. Tried going in and out of Werian Sanctuary. Tried travelling back to kingshill then back to Silfmoor. Logged out/in. Deleted & re-added task. Have not deleted DSO folder because it took bloody forever to download earlier today when I was forced to reload it after the thin-client crashed hard.

    Can't click on the statue, quest guidance doesn't even point me to it (but I'm pretty certain I've found the correct statue).

    MODS: Is this considered feedback or a bug report, and as such belongs elsewhere in the Forum?
  16. Mal3ficent

    Mal3ficent Guest

    dkarl likes this.
  17. Ash

    Ash Advanced

    Thanks. And the wiki updates look good. Did you purposely cut off the maps from the screen captures?

    1. Save the Souls - is it intentional to allow anyone in the map to break a statue and thereby render your chances null? I finally got the northern statue showing, only to have other players doing the same quest click on it, which made it impossible for me to do it.
    Or perhaps that's the initial problem.
    Tried new instances, tried dropping and retaking the quest four times. No luck.

    2. Lair Affairs. I'm glad it worked for you but that's hardly a basis for conclusion that there isn't a problem. The quest had checked off the second part - to recover the tome - plus the tome/column was no longer glowing after I clicked it. Then I clicked quest guidance for the last part - back to Werian. Back at Werian, the second part was no longer checked.

    3. The Wild Hunt
    After riding around like a loon. I found what appeared to be the same place as your wiki image. And what I found was the dead body of a peircer - a previous player? I couldn't do a thing.

    Returning later, the body was gone, yay, .... except but I couldn't click the stone.
    edit: it sometimes made the click sound, but nothing happened.
  18. trakilaki

    trakilaki Living Forum Legend

    Yes ... I only keep them in the screens if they are necessary.
    Good question ... but addressed to wrong person. The instances are bugged because they act like this map is a dungeon but in fact it is a open map ... there is a instance that is not bugged ... but half-bugged. :D Why? Because you can get the object ... but someone can use it before you can. I managed to finish the quest in TS because there were no other players to obstruct my quest.
    In fact the whole Western Area is bugged (read below).
    If you open the quest tab you can see it requires 2 Tomes (why? I have no bloody idea) ... it says 0/2
    That means when you click on the stand ... you should leave the map and enter again and click on it again.
    Finished this quest at TS and with 2 characters at live server.
    Like I said above the whole Western Area is bugged. You can get the statue (Save Their Souls) ... you cant click on the Flat Stone if someone already did it before you ... and the other thing is you get the fragment (Body of black-furred piercer) not from the piercer (deer) but from the mauler (dog). And when you place the body on the stone it still shows body of a deer.
    I already knew the quests are screwed up ...
    ... I did report them but like always they released them without fixing.
    What can I say ... either wait for the fix or try your luck and find working instance without players on it :eek:
    Though I know ... but i can't help further except giving you suggestion.
    Morinphen likes this.
  19. dkarl

    dkarl Forum Duke

    SUGGESTION: When clicking on a Chapter heading, don't automatically expand it to show all 30, 40, 60-odd tasks. I mainly want to see my progress summary for each Chapter, not review all of the individual bits of history every time. Make that expansion intentional, with a double-click required.

    Also, as I snidely noted earlier (apologies for the attitude ;)), seeing what I've completed isn't especially interesting or relevant to progressing in the game: I want to know what I've yet to complete. In fact, I really want to know which tasks I haven't even accepted yet ... as a "completist" returning to these earlier Acts & Chapters, it's not always easy figuring out what the game thinks I've skipped, as the quest givers hide their exclamation marks from my more "advanced" toon. Listing not-yet-accepted tasks would also help newcomers figure out where those tasks are located so they could make their runs more efficient.
    Morinphen likes this.
  20. redbugmoo

    redbugmoo Forum Greenhorn

    I prefer the quest log before Rel164 because it looks much tidier and simpler to view without needing to scroll [I'm a lazy player!]. But now we can hold more than 10 quests which is a big plus.
    The Compendium is a nice addition but it doesn't show our progress correctly.
    Thumbs up on the swapping essence feature! This indirectly gives us one extra inventory slot :) But everytime I change it's shortcut-key and re-login, the shortcut-key revert to 'X' :(
    I dislike the orange dim glow of "!" and "?" on NPC's with quests. Bright yellow "!" and "?" are perfect to gain our attention, why changing it?
    And to my dismay, repeatable quest [not pvp/Thabo] has the same colour with ordinary quest :( Now I have to open my eyes wider to spot the normal quest from the repeatable ones. It's a bit challenging for those with lazy eyes, ya' know! >.<
    I wonder what will be the colour for event quests. We shall see on Friday. Hope I'll not be disappointed again!!

    As others have pointed out on Werian's quests bug, I still unable to complete "Save the Souls 2/3" and "The Wild Hunt 2/3".
    I've tried changing instances numeral times and waited for almost an hour before I got fed up and discard those quest for now.