Release 214 Q/A

Discussion in 'Discussions on Current Topics' started by elitecrew1031, Dec 11, 2018.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
Thread Status:
Not open for further replies.
  1. Neblix

    Neblix Forum Greenhorn

    the runes of wisdom do not fit into any slot of begging equipment that can be used.only on the shoulders with before.because?Does anyone know what happens?
  2. Yogo

    Yogo Forum Great Master

    Hi there. You can fit into your equipment up to 5 Runes of Wisdom , so basically when you have 5 of them sitting in your Pauldrons, you shan't be able to fit another - the 6th, 7th, 8th etc, -runes in any other piece of your equipment. In the screenshot below I have 4 Runes in the Pauldrons and so I was able to fit the 5th (final) rune into the Cloak:

  3. trakilaki

    trakilaki Living Forum Legend

    Kiwigal1244 and Zoltan like this.
  4. Zoltan

    Zoltan Junior Expert

    Should have known the answer was in Wiki ;)
    trakilaki likes this.
  5. .RakshaRanja.

    .RakshaRanja. Forum Pro

    So my old equipment refiners got converted to this:

    But when I want to actually reroll my stats this is the error Im getting:

    I can buy them, yes but ONLY in stacks of 5:
    [​IMG] [​IMG]

    Why would anybody think that selling these only in stacks of 5 is a good idea?
    What am I supposed to do with them now? Sell them? They're bascially useless since no matter how many times I buy them I'll always end up 4 remaining refiners that I cant use.

    Yall so smart I cant even comprehend the thought process behind this.
    MikeyMetro likes this.
  6. Atsalakotos

    Atsalakotos Someday Author

    Goodmorning ...
    I start with a screenshot

    Really t8 items ? i searching about feedback and i dont see nothing just from players who obtain this kind of items ... So , this is how we burn our brains to find this kind of items and ..

    My Question is ..Ok maybe i will decide to burn my brain and at the end maybe i will find 4* pink heads or something else ..we can combine them or we can pass them at our uniques for have t8 items or is just a mistake of bp

    I need a clear answer to this !
  7. rcch

    rcch Advanced

    This is easy, you get one t8 item as a drop (green,blue,pink does not matter) . Let's say helmet here. You put this on workbench on other 3 slots you put 3 random helmets of same color->roll the dice(you have 25% chance to get t8 helmet )... repeat until you have leg helmet of t8... upgrade then your unique. Simple as that, problem is to get t8 item (0.05% ) so if you pick 1000 items on INF4 then in theory 5 of those are t8 items.
  8. deliburan78

    deliburan78 Advanced

    One question - why selling price for 2h weapons is reduced like a another legs , but craft prise is twice more expensive like before r 214 ?o_O Second question - why in every 30 min game crash??:mad:
  9. Orendik

    Orendik Forum Greenhorn

    Where is the workbench in Kingshill? I can't find one.
  10. _Baragain_

    _Baragain_ Living Forum Legend

    They are literally all over. They look different, but I can think of no less than four off the top of my head without even looking at the map.

    1. To the right of the Jeweler.
    2. To the right of the Black Smith.
    3. To the right of the guy who gives you the crafting quest.
    4. To the right of the pet/mount merchant.
  11. Orendik

    Orendik Forum Greenhorn

    Well, when I use Quest Guidance it say "There is no workbench in this area. Please try a different map." I can for example see what you mean, there is sort of a workbench beside the jeweler. But nothing happens when I click it, then I tried both right and left click. I've also restarted the game, still no luck. No 3 is gone, that's the one I used to use.

    As I'm lvl 10 now, restarted my account, I can't go to any other area.
  12. ghostmagicus

    ghostmagicus Forum Pro

    Cant find where Guardian Soul (that revives u) can be buyed with matery, any clue?

  13. sargon234

    sargon234 Commander of the Forum

    the priest in kingshill
  14. couda22

    couda22 Forum Commissioner

    As of R214, the offer has been removed (for obvious reason).
  15. ghostmagicus

    ghostmagicus Forum Pro

    Thanks for answer. The only obvious reason that comes into my mind, is that BP plans to make money on souch kind of resorces as essence, ressurection, etc, still, it was nice if they announced before this change.
  16. _Baragain_

    _Baragain_ Living Forum Legend

    Level up. If I'm reading the release notes right, LVL 12 is the lowest level that crafting is available.
  17. double270

    double270 Forum Apprentice

    Someone knows where i can find the recipe as the workbench says,because i think it doesnt exist? [​IMG]
  18. Anyki

    Anyki User

    There is no recipe. Right click on the enhancement gem and it should allow you to use it, similar to an item refiner.
  19. 9ndrei

    9ndrei Forum Expert


    I really think this is a bug and it's not intended. If it is (intended), it's stupid, so I doubt it. I've been solo-ing Infernal 3 maps. Once I've cleared the map, the Sentinel appears. I get to the fighting, take a percentage of its life and then die. 2-3 seconds after respawning on the map, I get the notification in the middle of the screen that "The mighty sentinel was defeated" (or something like that) and the boss disappears from the map. No chest, no loot, nothing.

    This has happened twice in the last 2 days.. and pardon me, we're not all OP and we can't clear these maps with ease. After 20-30 minutes of using essences, I expect to get the sentinel's chest.

    Can a mod confirm that this is a known bug or that it will be added to the buglist?

    I'm sorry, but I don't care for using essences and ander (sometimes) to have the reward ripped away from me at the last minute.
  20. ΣMiwel

    ΣMiwel Forum Ambassador

    I don't think it's a bug.
    That's one of the new possible sentinel enchantments.
Thread Status:
Not open for further replies.