Bug Safeguard of Balance Quest stuck?

Discussion in 'General Archive' started by Shadowdonkey, Mar 28, 2015.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
Thread Status:
Not open for further replies.
  1. Shadowdonkey

    Shadowdonkey Forum Greenhorn

    My lvl 31 Ranger is stuck on the Safeguards of Balance quest from Prince Aldred in the RC Center. I have the Head from the Herald but it is not triggering the quest as completed. No Question mark over Aldred's head and clicking on him it shows I have not gotten the head but I have it in my bag?
  2. trakilaki

    trakilaki Living Forum Legend

    Did you tried to click on that portal like stone in the center of the Herald's room?
  3. Shadowdonkey

    Shadowdonkey Forum Greenhorn

    No stone there, just a green circle on the ground.
  4. _Baragain_

    _Baragain_ Living Forum Legend

    There is the age old method of dropping the quest and re-accepting and trying again.
  5. Shadowdonkey

    Shadowdonkey Forum Greenhorn

    Yeah I may try that next.


    Just re took the quest twice. Worked after two attempts. Odd!
    Last edited by moderator: Mar 28, 2015
Thread Status:
Not open for further replies.