Bug Shops dont work

Discussion in 'General Archive' started by koliko72, Jul 21, 2015.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
Thread Status:
Not open for further replies.
  1. koliko72

    koliko72 Forum Greenhorn

    After patch 154 shops and quest geveers dont work
     
    AwesomeJenkins likes this.
  2. trakilaki

    trakilaki Living Forum Legend

    That glitch was present to TS ... I guess they didn't removed it.
    Try changing maps eventually you will manage to click on NPCs.
     
  3. Evilsheldock

    Evilsheldock Forum Apprentice

    changing maps does not work for me, and all npc's outside of kingshill are bugged since new release
     
  4. bloodyneo

    bloodyneo Forum Master

    same problem happen with me ..this game become hopless each release :((
     
  5. jeffzrx

    jeffzrx Advanced

    me too

    --MERGED--

    can't click them open
     
    Last edited by moderator: Jul 21, 2015
  6. fds667200

    fds667200 Forum Apprentice

    I'm having an issue with accessing certain NPCs, like Thabo the fragment exchanger or my kobold storage.
     
  7. edrogers56

    edrogers56 Forum Greenhorn

    Every Update things go badly wrong
    Can not access NPC's to melt
    Chat dropping out
     
  8. .P.trick

    .P.trick Forum Greenhorn

    There are a large number of problems trying to interact with NPCs. Why?

    One cannot complete quests, trade or get any sort of menu with them.

    This has happened twice so far to me - both times when having finished a duel.

    Release 154_11
     
  9. teddy.bear

    teddy.bear Team Leader Team Drakensang Online

    Greetings Heroes,

    Unfortunately a solution has not been found for fixing the NPC interaction today, so we apologise for the inconveniences caused. All we can do at the moment is assure you that the issue is known an it is being worked on, and recommend you to try NPCs from different urban areas - if you're lucky, you might find a few that are accessible.

    We appreciate your patience while a fix is being worked on.
    Best regards,
    teddy.bear
     
    Darwarren1 and fourtwenty68 like this.
  10. Laxerious

    Laxerious Forum Apprentice

    On Tegan server..no Merchants can be accessed for me and others.....can't repair...combine or buy anything.I hope it will be resolved soon....makes for terrible game play lol...I mean all Merchants all towns "none can be accessed"
     
  11. fourtwenty68

    fourtwenty68 Board Analyst


    told my guildy's and and they said it works in PW. thx TB:)
     
  12. maancrust

    maancrust Junior Expert

    Same thing for me, can't enter into dialogue with merchants and quest-givers. A friend told me to leave and re-enter a map for the problem to go away, which I did, and it worked... until I changed maps again, then it was back to square one.
    The worst thing is the bug reappeared when I was on the event map so I couldn't complete my quest for Thabo by speaking to the prisoner. Then I tried leaving the map to farm some more corrupted andermagic and re-enter event in the hope that it would work the second time, but no such luck.
     
  13. EmeraldRoyalKnight

    EmeraldRoyalKnight Forum Greenhorn

    Shops still don't work and I've tried everthing from switching maps, to logging out and in various times, to re-booting my system twice, to managing and updating my mouse hardware and software, to pulling my hair out and nothing works. You can't play if you can't buy, sell and repair. Please fix this problem ASAP! Thank you! Danke schon!
     
  14. Mikumon

    Mikumon Forum Apprentice

    Hello.

    Starting today after I logged in to the game I noticed I couldn't talk to most NPCs

    I didn't pay much attention to it in the beginning but later I realized that I can't do my daily challenges..
    I couldn't complete the quest that I had since the previous day cause
    > here's my problem <
    Every time I click on an NPC to talk to them my character keeps walking towards them forever and also the NPCs have no collision.. like I can pass through them if I don't click on to them.

    I tried to clear cookies and everything and ofc restart pc
    Also the problem started on the client and it continued on Firefox and Chrome.
    Is there a way to fix this? Or will I not be able to talk to an NPC ever again? lol

    Thanks in advance.
     
  15. Guitarman

    Guitarman Forum Master

    I have the same problem. I could not talk to Tabo in Andrakash but I can only initiate in quest King's Hill.
     
  16. Mikumon

    Mikumon Forum Apprentice

    Ya I noticed I could only talk to the Giant who sells mounts in Kingshill.. I didn't try the other NPCs there but the other areas that I tried wouldn't work.

    EDIT: just tried again and I can't talk to any NPC even in Kingshill
     
  17. edrogers56

    edrogers56 Forum Greenhorn


    If you can not fix it straight away and ruin game play for so many players why don't you remove the update altogether and fix the bugs first before reinstating it ?
    Do you guys even play the updates before you install them ?
     
  18. Mal3ficent

    Mal3ficent Guest

    Are you asking the forum moderators or the devs?
     
  19. bezryl

    bezryl Active Author

    same problem, all i get is the endless clicking noise and my toon runing at the npc's

    this bug is really game breaking, no selling items no buying no melting no quests
     
  20. edrogers56

    edrogers56 Forum Greenhorn


    Developers of the game
    Do they play the game at all ?
    The Rift of Realms 3 green ticks go to talk to Chocoliati and run on spot
    How many people is this happening too ?
     
Thread Status:
Not open for further replies.

Share This Page