Useless Rubbish

Discussion in 'Quests' started by FacePaint, Jul 11, 2019.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
  1. FacePaint

    FacePaint Forum Greenhorn

    I just came back to the game after a long time off... I have a quest Useless Rubbish that says I am 3/3 and just to go to the bench. I go to the bench and go to quest and it says I have the items but the combine button does nothing. Am I missing something about crafting... or something obvious I am overlooking?

    I was excited to return seeing so many changes to make the game more robust but this is beyond frustrating -
  2. trakilaki

    trakilaki Living Forum Legend

    What level is your toon?
    You need to be level 12 in order to use the workbench.
  3. FacePaint

    FacePaint Forum Greenhorn

    I am level 41. When the game was relatively new I played a lot, was anxious to dive back in and see all the new features but the simple task of completing this quest is eluding me... not sure I want to come back if something as silly as a low level quest and using the workbench is this difficult to do. :(
  4. trakilaki

    trakilaki Living Forum Legend

    I don't know why you can't use the workbench or the "combine " button.
    This toon is old ... so I got the quest and got to 3/3.
    All you have to do is right click on the quest item so you can place it on the workbench

    Then you should be able to use the "combine" button and craft the item ...


    ... and finish the quest.

  5. ShortFuseLiakos

    ShortFuseLiakos Forum Greenhorn

    Hi , I can't mix green items. I'm level 30 and I don't have the quest useless rubbish . When I go to the NPC who gives it , he will not give it to me. I have the quest master from disaster and I can't proceed. I also bought the things from Petyax so I can mix any item except greens. Please help.
  6. Larix

    Larix Forum Greenhorn

    After a few months i came back to the game. When i log on i saw new Kingshill and start playing with my old 20lvl mage character. After a few hours of playing i tried to combine gems but i couldnt. It said that I have to complete Useless rubbish and use Crafting primer but i have no quest for it anywhere.
  7. trakilaki

    trakilaki Living Forum Legend

    With the new R227 the quest is dependent of the previous quests in Hagastove Grotto and the main quests.
    You need to finish them all in order to activate Useless Rubbish.
    Also ... pay attention on the minimap you may miss it because it is marked green.
  8. Larix

    Larix Forum Greenhorn

    I know that and i feel like i did that quest before new Kingshill and i know that crafting quests are marked green but i really cant find it anywhere. I went through all cities. On the others 3 cahracters its working.
    Last edited: Jan 29, 2020
  9. Bit2easy

    Bit2easy Forum Greenhorn

    Can you fix this issue, im already level 55 and cant get quest useless rubbish i have done all quests! but this one didint shown for me.
    HOW I CAN PLAY IF I CANT CRAFT EDIT GEMS?????????????????????????
    Last edited by moderator: Feb 22, 2020
    theo200 likes this.
  10. $$DEAD$$

    $$DEAD$$ Forum Greenhorn

    Hi guys, I have the same problem with crafting. I cant find this quest. I am already lvl 57 but there are no quest for me regarding crafting gems
  11. dkarl

    dkarl Forum Duke

    What quality of gems are you trying to craft? You have to build up your skill level starting with crafting Splintered from Flawed gems + Shiny Dust (what you get when you grind Gems and Jewels at a workbench) and Simple Gems from Splintered + Shiny Dust. You have to do each of those initial crafts x number of times before you get the Achievement All These Gems I ... which will give you the crafting recipe Schematic: Gems I to allow you to craft Gems (the next quality after Simple), Polished Gems, and Radiant Gems. Craft enough of those three levels of gems and you'll get another Achievement / the next level of crafting manual. And so on.

    Other things to check:

    1. Open your Journal
    2. Select the Compendium tab
    3. Expand Act I on the left ... you should see 6 Chapters
    4. Expand Chapter 2 ... the bottom right of the Compendium window should show 9/9 (i.e., that there are 9 main+side quests in this chapter and that you've completed them all)
    5. Navigate to Kingshill in the game
    6. Almost immediately to the right (slightly NE of the travel stone), you'll find a small shack with the Jeweler Garnet standing at the southern wall
    7. Walk around to the NE corner and you'll find NPC / Quest Giver Matthew Allthings
    8. If he has no quests for you, walk E (left) by SE, just past the travel stone in the other direction to find Crafting Master Petyax
    9. If he has no quests (or at least nothing other than the repeatable quest Bone Oracle), open your Journal again and select the Achievements tab
    10. On the left, expand the Crafting list
    11. Select Gems & Runes
    12. The first item in that sublist should be Spintered, Not Polished and should have an x / 15 counter showing how many times you've crafted Splintered gems
    If you still can't create even Splintered Gems, send a ticket to Support asking them to mark the initial crafting quests completed for you.
    trakilaki likes this.
  12. trakilaki

    trakilaki Living Forum Legend

    Check the link above.
    Here i made fresh screenshots for you :)

    Before finishing the quest-

    after finishing the quest-
    jelbeat likes this.
  13. $$DEAD$$

    $$DEAD$$ Forum Greenhorn

    HI, thanks for your response guys. I have crafting achievements all the way to the radiant. However I cant find any of the quest you have mentioned. I am able to craft gems from shiny dust I got from somewhere, but I cant dismantle gems into shiny dust.
    I guess I should try completing every quest left from the beginning. I've already tried contacting support but operator was [EDIT].
    So far thank you for your help
    Last edited by moderator: Sep 30, 2021
  14. dkarl

    dkarl Forum Duke

    Hmmm ... so you can craft, you just don't have the necessary ingredient, Shiny Dust?

    There are several different variations of workbenches, with some differences in default behavior.

    If you open the workbench next to Petyax in Kingshill and drop a gem on the workbench, it will assume that you want to grind it into Shiny Dust.

    If you walk back to the workbench next to Matthew Allthings, open it and drop a gem on it, that version of the workbench will instead assume that you want to craft the gem up to the next higher level.

    At any variation of workbench (there are a few others), you can override that default action by choosing the function you want it to perform before you toss in the gem.

    For example, at the workbench near Matthew, click on it to open the workbench, then choose the 4th horizontal tab with the icon of a beaker and "Consumable Items" as the tool-tip name. Expand the last category in the list, Ingredient Crafting. You may need to scroll the list up to see the sub-options of that item. Choose Shiny Dust, then drop your gem on the workbench. It'll tell you how much gold or andermant it will charge you to grind your gem. Hit Combine and voila.
  15. $$DEAD$$

    $$DEAD$$ Forum Greenhorn

  16. EmilyRose

    EmilyRose Forum Commissioner

    maybe you have to do all the quests in Hagastove grotto ...
    Last edited: Oct 2, 2021
  17. $$DEAD$$

    $$DEAD$$ Forum Greenhorn

    But I can't find any, it looks like I already finished them before. I haven't been playing probably for 4 years and I just came back to the game
  18. EmilyRose

    EmilyRose Forum Commissioner

    Go to Grimford and look if you have some quest to do...maybe is this your problem ...
  19. stef0477

    stef0477 Forum Greenhorn

    Hello, I would also like to solve this "useless rubbish" mission, I have read about previous people's problems and tried to solve it myself, but I still haven't succeeded. Thank you and I would really appreciate a little help if may be!:D:D
  20. StayinFrosty

    StayinFrosty Someday Author

    What are the specifics of the problem that you are having, is the quest missing? If so, then make sure you finish main storyline quests like previously mentioned. It should only require that you complete the ones between Grimford up until the point that you reach Kingshill and is level 12 or above.
    -JustForFun- likes this.