Support Too slow and lag

Discussion in 'Technical Support' started by Baallith, Oct 28, 2021.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
  1. Javah

    Javah Forum Duke

    As you all can see, I do not answer or argue because, unlike others, I have little free time and I am not interested in losing it in discussions that add nothing to what I already know.

    So, as days ago I reported the anomaly of latency and loading times that made impossible any attempt to play (in this game and only in this one, I repeat), now I report the return to normality as well: I have done some runs from Monday to yesterday, and everything has normalized, that is, it has returned to the values prior to my report, which are more than acceptable on my side as far as I'm concerned.

    If someone on the company side intervened, as it could be, given the no longer anomalous results of the tests towards the servers, I thank him/them.
     
    Kiwigal1244 likes this.
  2. BeardWeird

    BeardWeird Forum Greenhorn

    Same. Got a semi-decent PC and 300mbps fiber net, but its still lag esp. when we port to a map or a bunch of mobs approaching..
     
  3. MisterNoob

    MisterNoob Advanced

    You know whats funny? When experiencing big lag, look at the clock on your computer...
     
  4. Kiwigal1244

    Kiwigal1244 Active Author

    :rolleyes: Exactly. I have timed how long it takes to for map to load. averages 30-40secs
    Would be so lovely to return to normal play and load times.
     
  5. Javah

    Javah Forum Duke

    I know I can not help, but to me personally the problem is still not present at the time: I actually have 50-60ms in game with 4g network latency 35-45m, that's pretty fine for my low expectations, and map's loading time is "as usual" considering such parameters.

    However, some of my guildmates are now complaining about the same problem as you: and some of them have fiber with 5-10ms latency. The curious thing is that when I had problems, they were able to play without difficulty.

    In any case, I guess it will soon be a non-problem: Bigpoint seems to have disappeared, ditto its "DSO team", so I suggest to don't worry for lags cause the path of no return is well taken (and, if this were not the case, it would be smart if the company gave a signal of state in life, cause more and more players are drawing their own conclusions).

    That said, if someone on the developer side resolves the lag issue definitively and for everyone, better anyway. I just could suggest you to read this thread meanwhile, translating it in the language you like more: https://board-en.drakensang.com/threads/netkapcsolodas-tesztelese-keses-lag-hibaelharitas.84557/

    Remember also to always check your DL / UL bandwidth besides of the sole ping indicator, and the CPU occupation: your computer may be downloading something large in background (for example, Windows updates) or having a hanged process in memory. But of course these issues will reverberate on all the activities you perform on your PC, and not just on this game.
     
    Last edited: Feb 12, 2022
    Kiwigal1244, Elendel80 and gbit like this.
  6. MisterNoob

    MisterNoob Advanced

    This is not exactly what I was pointing on :) Much more to check the clock, what it is showing. I noticed the big lags appears always on whole hour (xx:00). Sometimes few seconds off, I quess it depends on server clock, not computers.
    Oh and my lags are more like 5-20 secs.
     
  7. uparse43

    uparse43 Forum Greenhorn

    I am aware and I know players who are having lags even if they are using cable, in fact some of them are not even able to play the game at all since the map is not loading at all, and the issue is clearly not at their side.

    hellodear.in
    teatv.ltd
     
    Last edited: Jun 20, 2022
  8. Babis3891

    Babis3891 Forum Greenhorn

    For the last 4-5 months its unable for many gamers to change maps without a min delay of 10-20-30'' sec.. As me as well ... and hapens in all maps : cities , parallel, dungeons , final bosses .Playing the game since 2014, I' ve never been so nervous. Its in vain to follow teams , to kill the Slangs in chests..I have prime net VDSL 100 Mbs connection and the only game - page that is been infected and lags is DSO..Tired to see the Cat of Kingshill , walking through the map ..It takes half of tiime seeing the yellow page than farm ..and Deluxe is counting , Try to fix this issue , think its been mentioned from many of gamers, for such a long time !
     
  9. Babis3891

    Babis3891 Forum Greenhorn

     
  10. 100100asd

    100100asd Forum Greenhorn

    Тоже такая проблема с задержкой , пару месяцев назад сломался ПК купил новый скачал запустил игру и нет проблемы , буквально пару недель порадовался и снова началась эта проблема , думаю это нарочно ( специально ) делают !
     
  11. mystic_archer29

    mystic_archer29 Forum Apprentice

    I've already said it like 5 times in 5 different threads, but i guess nobody will listen.

    The 'RakNet' library that DSO uses is not supported on win10. Its a networking library, basically it is an endpoint between the client and the internet (actually OS first then the internet).

    The implementation(the library) Hangs on fetching data from AMAKAITECHNOLOGIES content delivery network (CDN) in an infinite loop, thats why it cant load, because it cannot finish/escape the loop. Some of the data packets are missing, your account is not fully loaded. Then it asks again, and again it doesnt get all the data, so it cant load. So it times out again, asks for data again, incomplete data is received, and it times out.

    Then asks again for the account data, incomplete data is received, and it gets timed out.
    Then asks again for the account data, incomplete data is received, and it gets timed out.
    Then asks again for the account data, incomplete data is received, and it gets timed out.
    Then asks again for the account data, incomplete data is received, and it gets timed out.
    Then asks again for the account data, incomplete data is received, and it gets timed out.
    Then asks again for the account data, incomplete data is received, and it gets timed out.
    Then asks again for the account data, incomplete data is received, and it gets timed out.

    you get the idea.

    This problem is more apparent on loaded characters with tons of achievements/items etc. Go make another account and you will never run into this problem untill you hit some achievements and your character gets some items, pets etc.

    How many times do i have to create a thread for it ? And why this nonsensical speculation? Clear your cache? Same result as taking a walk around the house. Or maybe try calling your girlfriend, try to drink a glass of water perhaps? Tried that too? Stop making blind guesses in an architecture composed of 100s' of elements, spend some time understanding what goes on 'under the hood' and then make intelligent decisions, not blind guesses.

    Why is the issue more apparent nowadays? Because win10 superseeds win7. This is win10 related issue (and of course RakNet library), and the more people use win10 the more people hit the bug.

    I've sent this like 3 times to the support, but those brainlets rather lose half the player base than spend 1 day just swapping out the library to something win10+ compatibile.
     
    Last edited: Jun 19, 2022
    Айлейд likes this.
  12. Carlo5

    Carlo5 Forum Greenhorn

    o problema persiste
     
  13. CreativeMan

    CreativeMan Forum Greenhorn

    The problem with the game is that it downloads currently needed files while you play. What's even more funny, all these files are temporary so sooner or later they will be removed from your PC after some amount of time. It doesn't matter how fast your internet is because download speed from their servers is just bad. After 10 years nothing has changed with that. It's even worse because there is more files to download. Players should have a choice to download only necessary files or download all files to play the game without annoying short freezes or watching all models pop in. Years back I thought that was caused by my old PC with Core 2 Quad, 4GB of RAM and HDD. Now I have Ryzen 7 5800X, 32GB RAM DDR4 CL16 3800MHz, 1TB NVMe SSD and RTX 2080 Super. The situation is still the same, only framerate is higher o_O

    Btw. devs should think about replacing an ancient DirectX 9 to some nower API. According to Steam hardware survey, most of the users have CPU with at least 4 cores. DirectX 11 (still limited to 4 cores) provides multicore draw calls, while DirectX 9 is limited only to single core draw calls. We could expect higher and more stable framerate if graphics wouldn't be touched.
     

Share This Page