FileNotFoundException

Discussion in 'Technical Support' started by DocWhisky, Oct 6, 2017.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
Thread Status:
Not open for further replies.
  1. DocWhisky

    DocWhisky Forum Connoisseur

    Hi all, Been having trouble logging into TS, using Internet Explorer. Keep getting a file not found exception. Have dumped the DSO client folder and it didnt help.
    The exception reads:
    https/stablebuild.drakensang.com/applet/applet32_ng.jar.ea2abc5eafbfbf184f62abce2db01sec.

    The java console gave this report:
    java.net.MalformedURLException: unknown protocol: httpnz
    at java.net.URL.<init>(Unknown Source)
    at java.net.URL.<init>(Unknown Source)
    at com.sun.deploy.uitoolkit.impl.awt.AWTDefaultPreloader$GrayBoxPainterStarter.run(Unknown Source)

    Have sent ticket to support. No answer for error so far and this close to weekend, doubt one is coming. So I am asking the DSO community to see if any of our players has some insight.

    Thanks, Doc.
     
  2. trakilaki

    trakilaki Living Forum Legend

    Hey Doc ... you mean this one? :)

    [​IMG]
    A nasty one ... i can tell you that . I could play at Live Server but Java was not working with the TS.
    looks like there is some linking error/typo
    httpnz in the address ... it should be https:// ...
    anyway ... this is how i managed to make Java work.

    1. Installing new clean installation of the latest Java version won't work.
    2. uninstall Java completely
    3. delete all folders (with Java, Oracle or Sun name ) at C partition ... including Temp Folder (don't delete DSOClient folder inside the temp folder ... you can delete everything else inside the temp folder)
    4. Restart your system
    5. Install the older JRE version 1.8.0_131 (you can try with the latest version but it was not working for me)
    6. You won't be able to see the "Play Now" button ... because the version is older ... so go to Start - All programs - Java - start the "check for updates" option
    [​IMG]
    After that it should be working.

    I had the same issue in the past few days ... and I managed to fix it ^ that way ... make sure you follow all the steps.
     
    Last edited: Oct 6, 2017
    DocWhisky likes this.
  3. DocWhisky

    DocWhisky Forum Connoisseur

    Yes Sir. Thats the lil bugger thats given me grief.
    Thanks for the work around Trakilaki, your help is much appreciated :)

    This whole thing brings rise to the question once again as to why the DEV team has not made logging into TS a part of the main login screen on the client????

    Why do we have to either use separate venues to play live and TS versions of the game?? If this will always be the case, can we not get a client JUST for TS??? Please??... Pretty Please?? :):D:cool:

    Just like Trakilaki said in this post (https://board-en.drakensang.com/thr...r-not-working-to-play-game.73195/#post-666398) way back in march

    Thanks, Doc.
     
    trakilaki likes this.
  4. SillySword

    SillySword Padavan

    Consolador likes this.
  5. Consolador

    Consolador Forum Greenhorn

    The same issue on Grimmag server. I tried Balor and it is working well...
     
  6. Llogos

    Llogos Junior Expert

    So, after the Hotfix today, I get the following message when I try to load the game:

    "FileNotFoundException error"
    clicking the details button brings then up this:

    ''Java Plug-in 11.66.2.18
    Using JRE version 1.8.0_66-b18 Java HotSpot(TM) Client VM
    User home directory = C:\Users\...
    ----------------------------------------------------
    c: clear console window
    f: finalize objects on finalization queue
    g: garbage collect
    h: display this help message
    l: dump classloader list
    m: print memory usage
    o: trigger logging
    q: hide console
    r: reload policy configuration
    s: dump system and deployment properties
    t: dump thread list
    v: dump thread stack
    x: clear classloader cache
    0-5: set trace level to <n>
    ----------------------------------------------------''

    What exactly has been fixed? I see that it's worse than before. The game was working perfectly fine for me before the hotfix, and now this. I bought premium and I can't use it as I can't play via client because I am on a metered connection.
    :mad::mad::mad:
     
    Last edited: Oct 9, 2017
  7. Have you tried the troubleshooting steps found in the Technical FAQ. In particular, have you cleared your Java Cache and made sure that your Java is up to date?
     
    Purpleoctopus likes this.
  8. Schlonz99

    Schlonz99 Forum Greenhorn

    I can logon to Heredur Server neither. I get the error message

    FileNotFoundException

    java.net.MalformedURLException: unknown protocol: httpnz
    at java.net.URL.(Unknown Source)
    at java.net.URL.(Unknown Source)
    at com.sun.deploy.uitoolkit.impl.awt.AWTDefaultPreloader$GrayBoxPainterStarter.run(Unknown Source)


    Java is up-to-date (Version 8 Update 144)

    Additional Information:
    1) The error only occurs with server Heredur. I can switch to any other server and get into the game. However, since I only have a character on Heredur switching to a different server is not an option.

    2) Reinstalling the latest Java version did not solve the issue.
     
  9. Chell2015

    Chell2015 Forum Apprentice


    It is not limited to the Heredur server only, I play on Agathon and have just gotten the exact same error when trying to load into the game as well, running in IE 11 with up to date Java as well. I would play using the client however it refuses to let me use it not matter how many times I install it, so I am forced to play through the browser or not play at all.

    Some one please advise on what the issue is and how to resolve it asap.

    Thank you for your time.
     
  10. trakilaki

    trakilaki Living Forum Legend

    Now ... with the latest hotfix ... the issue teleported to Live servers
    This time I could play at TS but not at Live Servers ... so i had to do it all over again.
    It is working again. :)

    This issue was present at TS ... now at Live servers .
    I found a work around that is removing the issue completely ... just follow all the steps here
     
    Last edited by moderator: Oct 12, 2017
    DocWhisky likes this.
  11. wolfie54

    wolfie54 Active Author

    Having the same error message and not able to log in (Agathon server). Will DSO fix this or must we continue to solve these issues ourselves. Thanks Traki for your persistence and perseverance on behalf of the community. I'm not real computer literate but will see if I can follow your instructions. The community would truly be in trouble without people like you.
     
    DocWhisky and trakilaki like this.
  12. trakilaki

    trakilaki Living Forum Legend

    Thanks Wolfie54 ... i am doing my best :)
    Let me know if you can't manage on your own ... i can make a video with all the steps and folders.
    But not earlier than this morning.
     
    DocWhisky likes this.
  13. wolfie54

    wolfie54 Active Author

    In looking for this older version to download, Oracle has me filling out an account page. I'm retired and have no information for many of the "required" fields. Looks like I'll need additional help.
     
  14. Purpleoctopus

    Purpleoctopus Forum Greenhorn

    A Java cache clearing did the trick.
     
  15. trakilaki

    trakilaki Living Forum Legend

    Try clearing the Java cache first ... if it works you won't need to uninstall Java
    This way:
    1. see the picture in step 6 above and click "configure Java"
    2. this window will appear
    [​IMG]
    In the first tab "General" ... under "temporary internet files" click "settings"
    3. the second smaller pop-up window will appear
    4. delete the files
    or you can go directly to the directory shown in the picture above and delete everything manually.


    I uploaded it to Dropbox
    You don't need to sign in or register ... just close the little window when asked to sign in.
     
    Last edited: Oct 10, 2017
    DocWhisky, Dragonnns and Schlonz99 like this.
  16. trakilaki

    trakilaki Living Forum Legend

    Cool ... i did that before doing anything else and it didn't help ... so i had to go with all those steps.
     
    DocWhisky likes this.
  17. wolfie54

    wolfie54 Active Author

    Clearing the Java cache did the trick. Thanks Traki for all your time and effort in helping me with this issue. Honestly, I have to say, you're more than a living forum legend. You're truly one of the good guys!
     
    trakilaki likes this.
  18. trakilaki

    trakilaki Living Forum Legend

    Nice .
    Looks like clearing the cache worked out for everyone but me :D
    Oh well ... if it was working for me too ... i would have 10-15 posts less now :D ... not everything is that bad after all :D
     
  19. SillySword

    SillySword Padavan

    It works, thank you. I see two DSO files in Java Temporary Files directory. Deleting them both and run DSO again, everything is fine.
     
    huskerdew likes this.
  20. Schlonz99

    Schlonz99 Forum Greenhorn

    That worked for me, too! Many thanks to you, pal.

    BTW, the Workaround of installing an older Version of Java is not suited for paranoid sercurity fanatics like me. ;)
     
    huskerdew likes this.
Thread Status:
Not open for further replies.

Share This Page