Bug ShaderServerBase Error.

Discussion in 'General Archive' started by HatzeFlatz, Feb 1, 2017.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
Thread Status:
Not open for further replies.
  1. HatzeFlatz

    HatzeFlatz Forum Greenhorn

    Hey someone,

    I have this problem.

    If I start the launcher of drakensang it will automatacly say this:

    ''ShaderServerBase: Failed to open shader package file 'httpnz://drasaonline-481.level3.bpcdn.net/cdndata/export_Win32/shaders/shaders_sm30'!''

    (Click the word under here for photo)

    [This] for foto

    If you could help me, please! I want to play this game!

    Bye,
    HatzeFlatz
     
  2. SweetRanger

    SweetRanger Forum Apprentice

    Upon loading client nebula error is coming up saying ShaderServerBase: failed to open shader package file never had this error before anyone else seeing the same thing? and if any ideas on how to fix?
     
  3. Rhysingstar

    Rhysingstar Forum Ambassador

    You mean this one? DSO patches live up to expectations all the time. They rush to release something, can't bother to test for bugs or errors, then patch it a day or two later with more bugs and errors.

    [​IMG]
     
  4. SweetRanger

    SweetRanger Forum Apprentice

    That's the one.
     
  5. SweetRanger

    SweetRanger Forum Apprentice

    Tried re-installing with no success, just the same message. Client acts like it's loading, but very slow, and not with same progression bar as usual.
     
  6. Wumpinator

    Wumpinator Forum Greenhorn

    I just started getting this error since logging in today too. Haven't seen any suggestion on a fix yet.
     
  7. User330K

    User330K Junior Expert

    Same here!

    [​IMG] [​IMG]

    Neither in client nor in browser...
     
    Selene-Rip likes this.
  8. booger73

    booger73 Forum Apprentice

    Right click on "Drakensang online" app. Go to properties
    Add: After the line "C:\Program Files (x86)\Drakensang Online\thinclient.exe" -stable
    Start up client.. Let it download and update.. don't log in
    Exit app

    Go back to app, go to properties.. get rid of the '-stable'
    Log back in as usual

    Works for me
     
    Hetsunien, ToshiBoy, Novadude and 9 others like this.
  9. trakilaki

    trakilaki Living Forum Legend

    If you are using client try what booger73 says
    But it is faster to go at TS with your browser and follow these instructions https://board-en.drakensang.com/threads/download-critical-file-error.72965/page-2
     
    SweetRanger and Tilwin90 like this.
  10. Tilwin90

    Tilwin90 Padavan

    Excellent approach. I prefer it to the browser one but maybe because I'm comfortable with command line arguments. :D
    I was getting a bit panicky I won't be able to login tonight. :rolleyes: Addiction, sweet addiction, you're driving me crazy.

    *begins ranting about Bigpoint's professionalism cause I really can't take this anymore*
    Oh my freaking lord Bigpoint, EDIT?! You can't even make a hotfix without breaking something? Let alone... erm... the game setup?! I'm sorry but I don't know what your release procedure covers... but it's definitely not testing the freaking setup kit! One of the most elementary tests you should perform prior to any hotfix.
    Dear lord... Even our junior developers know to perform this test on a dedicated environment before every go-live. Get your team to some freaking Devops trainings if common sense is not working, because such rookie mistakes are unacceptable. You're becoming less and less professional with every passing day.
    *ranting done*
     
    CyberSlayer and *Man-In-Black* like this.
  11. brandona1

    brandona1 Forum Greenhorn

    Boogers


    Worked for me too, thanks dude, was starting to piss me off
     
  12. *Man-In-Black*

    *Man-In-Black* Forum Apprentice

    Thank you booger73, worked for me :)
     
  13. thewiz6666

    thewiz6666 Forum Apprentice

    Why do these dev EDIT persist in ruining the game with continual goddamn updates that EDIT up my install and I have to redo all my setup with volume levels and hotkey assignments? Totally tired of this EDIT , luckily the prior mentioned fix worked for me, but had I not dug into this I'd lose my streak of several hundred days of logins which would infuriate me.
     
    Last edited by moderator: Feb 1, 2017
    *Man-In-Black* likes this.
  14. SmokingKills

    SmokingKills Forum Greenhorn

  15. Selene-Rip

    Selene-Rip Junior Expert

  16. Lawfer

    Lawfer Forum Greenhorn

    Hello, I have tried the only solution that seem to work for lots of people to resolve there problem with the client:

    Right click on "Drakensang online" app. Go to properties
    Add: After the line "C:\Program Files (x86)\Drakensang Online\thinclient.exe" -stable
    Start up client.. Let it download and update.. don't log in
    Exit app

    Go back to app, go to properties.. get rid of the '-stable'
    Log back in as usual

    But everytime that I open the client. There is always that nebula error that open.
     
  17. BigHink

    BigHink Forum Inhabitant

    walked guildie thru this fix and worked fine
     
  18. ProfStar

    ProfStar Forum Greenhorn

    is there someone that could help me with setting up the game, I am having issues and I read what some of you did, I am not that computer savvy yet and also I am dyslexic which makes it harder for me at times work my way around a computer. You can find me on Facebook or here...

    Peace LadyStarHawk
     
  19. dennisb1972

    dennisb1972 Forum Greenhorn

    Hello, i have the same problem and i'm not that technical ... and also a problem with the solution above.
    So my first question is, do i have to type '-stable' behind the line like this? "C:\Program Files (x86)\Drakensang Online\thinclient.exe" -stable
    But when i do that, i get an error that the path is incorrect. Or is '-stable' a term or a character.
    Sorry for my stupid question and thanks for any input.
    Thanks in advance.
     
  20. QueenieB

    QueenieB Forum Greenhorn

    hey add a space after "C:\Program Files (x86)\Drakensang Online\thinclient.exe" "space"-stable.... that worked for me :)
     
Thread Status:
Not open for further replies.

Share This Page